summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2012-10-02 20:27:32 -0700
committerJosh Blum2012-10-02 20:27:32 -0700
commitd4cd9770dc973c2a506faeca80777ccda93323e3 (patch)
treed93ec32c7e0969b01b9383b5c9eb5714fdae1ae7 /lib/CMakeLists.txt
parentbc1d4e117fab42150bc62d1940e142dd6d10aadc (diff)
downloadsandhi-d4cd9770dc973c2a506faeca80777ccda93323e3.tar.gz
sandhi-d4cd9770dc973c2a506faeca80777ccda93323e3.tar.bz2
sandhi-d4cd9770dc973c2a506faeca80777ccda93323e3.zip
added GRAS_DEBUG to be set in Debug mode
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 0ecd2d5..1eeb832 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -7,6 +7,10 @@ set(GRAS_SOURCE_DIR ${CMAKE_SOURCE_DIR}/../)
set(GRAS_BINARY_DIR ${CMAKE_BINARY_DIR}/gruel/src)
set(RUNTIME_SOURCE_DIR ${CMAKE_SOURCE_DIR}/gnuradio-core/src/lib/runtime)
+if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+ add_definitions(-DGRAS_DEBUG)
+endif()
+
########################################################################
# Setup Theron Deps
########################################################################