summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2012-08-27 21:09:24 -0700
committerJosh Blum2012-08-27 21:09:24 -0700
commit513d5dba726b5cbd4c2c8873d25ef979db04aa00 (patch)
tree9d92df25194026a43050e02acc8fd14e786db81d /lib/CMakeLists.txt
parent0323e54b99dbbf28f8c2290cc59b6bb06b9e6f37 (diff)
downloadsandhi-513d5dba726b5cbd4c2c8873d25ef979db04aa00.tar.gz
sandhi-513d5dba726b5cbd4c2c8873d25ef979db04aa00.tar.bz2
sandhi-513d5dba726b5cbd4c2c8873d25ef979db04aa00.zip
runtime: other changes to work with minimal core changes
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 090a244..8483a0b 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -82,6 +82,14 @@ install(FILES
COMPONENT "core_devel"
)
+#also copy these to the build dir for swig docs
+foreach(header ${runtime_headers})
+ execute_process(
+ COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_BINARY_DIR}/gnuradio-core/src/lib/runtime/
+ COMMAND ${CMAKE_COMMAND} -E copy ${header} ${CMAKE_BINARY_DIR}/gnuradio-core/src/lib/runtime/
+ )
+endforeach(header)
+
########################################################################
# Install swig headers
########################################################################