summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2012-10-04 20:49:54 -0700
committerJosh Blum2012-10-04 20:49:54 -0700
commit3600e927bf31ca46bb99ef2df83512112fa6a8b2 (patch)
tree3106624cc0c801b68094a590deb15a1efa6c56a8 /lib/CMakeLists.txt
parent47985be7403d16049d166ea1da4a94870c2c9606 (diff)
parentf4694482fdb682a3abf2ed58b334e377b852799f (diff)
downloadsandhi-3600e927bf31ca46bb99ef2df83512112fa6a8b2.tar.gz
sandhi-3600e927bf31ca46bb99ef2df83512112fa6a8b2.tar.bz2
sandhi-3600e927bf31ca46bb99ef2df83512112fa6a8b2.zip
Merge branch 'profile_work' into port_config
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index d1b878c..8f90824 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -11,6 +11,10 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
add_definitions(-DGRAS_DEBUG)
endif()
+list(APPEND gnuradio_core_sources
+ ${CMAKE_CURRENT_SOURCE_DIR}/register_messages.cpp #exports messages, must be first
+)
+
########################################################################
# Setup Theron Deps
########################################################################
@@ -54,6 +58,7 @@ list(APPEND gnuradio_core_sources
${CMAKE_CURRENT_SOURCE_DIR}/block.cpp
${CMAKE_CURRENT_SOURCE_DIR}/block_actor.cpp
${CMAKE_CURRENT_SOURCE_DIR}/block_task.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/theron_allocator.cpp
${CMAKE_CURRENT_SOURCE_DIR}/block_allocator.cpp
${CMAKE_CURRENT_SOURCE_DIR}/block_handlers.cpp
${CMAKE_CURRENT_SOURCE_DIR}/topology_handler.cpp