summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2012-10-21 15:53:11 -0700
committerJosh Blum2012-10-21 15:53:11 -0700
commit2a1966462484cf1cb25ea7802cc0d9a8e80096c9 (patch)
tree3ee9d69dae834a460541dca240c14868c9cc8add /lib/CMakeLists.txt
parent25ec793e687821bd2ac5862fcf934c4c9c0f47b6 (diff)
downloadsandhi-2a1966462484cf1cb25ea7802cc0d9a8e80096c9.tar.gz
sandhi-2a1966462484cf1cb25ea7802cc0d9a8e80096c9.tar.bz2
sandhi-2a1966462484cf1cb25ea7802cc0d9a8e80096c9.zip
getting API read for PMCs
Moved tags API stuff into gr block, specifically the get tags filters. The block class now has a simplified interface for dealing with input and output tags. Dummy typedefs for PMCs Tag class now uses PMCs
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 6081bb6..cfc957f 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -43,6 +43,7 @@ list(APPEND gnuradio_core_sources
${CMAKE_CURRENT_SOURCE_DIR}/debug.cpp
${CMAKE_CURRENT_SOURCE_DIR}/element.cpp
${CMAKE_CURRENT_SOURCE_DIR}/sbuffer.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/tags.cpp
${CMAKE_CURRENT_SOURCE_DIR}/block.cpp
${CMAKE_CURRENT_SOURCE_DIR}/block_actor.cpp
${CMAKE_CURRENT_SOURCE_DIR}/block_task.cpp