summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2012-11-13 22:48:52 -0800
committerJosh Blum2012-11-13 22:48:52 -0800
commit087b57cec17cc702a6e127c41e3058d58a38589c (patch)
treeadaad13ce9ceeede7694c19e48622674182b87b7 /lib/CMakeLists.txt
parent8b714226a0c73ccb458707126d73bae752186db6 (diff)
downloadsandhi-087b57cec17cc702a6e127c41e3058d58a38589c.tar.gz
sandhi-087b57cec17cc702a6e127c41e3058d58a38589c.tar.bz2
sandhi-087b57cec17cc702a6e127c41e3058d58a38589c.zip
explicitly define GRAS_DLL_EXPORTS for library build
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 3748830..870510a 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -61,6 +61,7 @@ list(APPEND GRAS_SOURCES
add_library(gras SHARED ${GRAS_SOURCES})
target_link_libraries(gras ${GRAS_LIBRARIES})
set_target_properties(gras PROPERTIES VERSION ${GRAS_VERSION})
+set_target_properties(gras PROPERTIES DEFINE_SYMBOL "GRAS_DLL_EXPORTS")
install(TARGETS gras
LIBRARY DESTINATION lib${LIB_SUFFIX} COMPONENT ${GRAS_COMP_RUNTIME} # .so file