summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2013-07-27 01:17:46 -0700
committerJosh Blum2013-07-27 01:17:46 -0700
commit7a677f768094fecfbb04e7b803c99cc2787153a2 (patch)
tree347e4bd306307bd0f9c979518f840bab00da5488 /CMakeLists.txt
parentb877d078b11cb848b344f4f7534398f70157aa15 (diff)
downloadsandhi-7a677f768094fecfbb04e7b803c99cc2787153a2.tar.gz
sandhi-7a677f768094fecfbb04e7b803c99cc2787153a2.tar.bz2
sandhi-7a677f768094fecfbb04e7b803c99cc2787153a2.zip
gras: work on module loading and python factory
naming convention, path convention, env var convention, And, make a python factory -- but its a little halfassed. You see, we didnt do the swig director thing yet, so C++ cant yet create python blocks from the factory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbab4a3..c3c9437 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,9 @@ if(MSVC)
add_definitions(-DBOOST_ALL_DYN_LINK) #setup boost auto-linking in msvc
endif(MSVC)
+file(TO_NATIVE_PATH "${CMAKE_INSTALL_PREFIX}" GRAS_ROOT)
+STRING(REPLACE "\\" "\\\\" GRAS_ROOT ${GRAS_ROOT})
+
########################################################################
# Component names for install rules
########################################################################