summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormaheshgudi2017-11-15 18:39:43 +0530
committermaheshgudi2017-11-15 18:41:37 +0530
commit401f1ae1fe5ae873cc0ac373b2b3e1add7ccf69c (patch)
treebe1ba69459800453c16a61d0a1c5b228d17cb151 /setup.py
parent50569f1f778260139fe7def6004576b2bffa2a3a (diff)
downloadonline_test-401f1ae1fe5ae873cc0ac373b2b3e1add7ccf69c.tar.gz
online_test-401f1ae1fe5ae873cc0ac373b2b3e1add7ccf69c.tar.bz2
online_test-401f1ae1fe5ae873cc0ac373b2b3e1add7ccf69c.zip
Update setup.py for PyPI release.
- Update release date on changelog.txt
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 5bc0a56..9fe5be5 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
import os
from setuptools import setup, find_packages
-README = open(os.path.join(os.path.dirname(__file__), 'README.md')).read()
+README = open(os.path.join(os.path.dirname(__file__), 'README.rst')).read()
# allow setup.py to be run from any path
os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
@@ -20,7 +20,10 @@ install_requires = [
'python-social-auth==0.2.19',
'tornado',
'psutil',
- 'ruamel.yaml==0.15.23'
+ 'ruamel.yaml==0.15.23',
+ 'invoke==0.21.0',
+ 'six',
+ 'requests',
]
setup(
@@ -37,7 +40,7 @@ setup(
'yaksh = yaksh.scripts.cli:main',
],
},
- description='A django app to conduct online tests.',
+ description='A django app to conduct online programming tests.',
long_description=README,
install_requires=install_requires,
classifiers=[