summaryrefslogtreecommitdiff
path: root/volk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'volk/Makefile.am')
-rw-r--r--volk/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/volk/Makefile.am b/volk/Makefile.am
new file mode 100644
index 000000000..d2ef3dad4
--- /dev/null
+++ b/volk/Makefile.am
@@ -0,0 +1,56 @@
+#
+# Copyright 2004,2008 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+ACLOCAL_AMFLAGS = -I config
+
+include $(top_srcdir)/Makefile.common
+
+EXTRA_DIST = bootstrap configure config.h.in
+SUBDIRS = config include lib
+#if USE_PYTHON
+#SUBDIRS += python
+#endif
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = volk.pc
+
+distclean-local:
+ -rm -f config/lv_set_simd_flags.m4
+ -rm -rf autom4te.cache
+ -rm -f config.*
+ -rm -f depcomp
+ -rm -f install-sh
+ -rm -f ltmain.sh
+ -rm -f py-compile
+ -rm -f missing
+ -rm -f volk_config.h.in
+ -rm -f aclocal.m4
+ -rm -f Makefile.in
+ -rm -f config/lt*
+ -rm -f config/libtool*
+ -rm -f apps/Makefile.in
+ -rm -f config/Makefile.in
+ -rm -f data/Makefile.in
+ -rm -f doc/Makefile.in
+ -rm -f include/Makefile.in
+ -rm -f lib/Makefile.in
+ -rm -f python/Makefile.in
+ -rm -f configure \ No newline at end of file