summaryrefslogtreecommitdiff
path: root/volk/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2010-12-07 18:50:28 -0500
committerTom Rondeau2010-12-07 18:50:28 -0500
commit239144659b29c0a5ecd83a34e0e57387a1060ed7 (patch)
tree3476e1c123da4696c64cc1756ddec5d971bcf9f2 /volk/Makefile.am
parente13783aeb84a2c3656c3344a8d52fa2c9ee38a00 (diff)
downloadgnuradio-239144659b29c0a5ecd83a34e0e57387a1060ed7.tar.gz
gnuradio-239144659b29c0a5ecd83a34e0e57387a1060ed7.tar.bz2
gnuradio-239144659b29c0a5ecd83a34e0e57387a1060ed7.zip
Initial checkin for VOLK - Vector-Optimized Library of Kernels. This is a new SIMD library.
It currently stands by itself under the GNU Radio tree and can be used separately. We will integrate the build process into GNU Raio and start building off of its functionality over time.
Diffstat (limited to 'volk/Makefile.am')
-rw-r--r--volk/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/volk/Makefile.am b/volk/Makefile.am
new file mode 100644
index 000000000..d2ef3dad4
--- /dev/null
+++ b/volk/Makefile.am
@@ -0,0 +1,56 @@
+#
+# Copyright 2004,2008 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+ACLOCAL_AMFLAGS = -I config
+
+include $(top_srcdir)/Makefile.common
+
+EXTRA_DIST = bootstrap configure config.h.in
+SUBDIRS = config include lib
+#if USE_PYTHON
+#SUBDIRS += python
+#endif
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = volk.pc
+
+distclean-local:
+ -rm -f config/lv_set_simd_flags.m4
+ -rm -rf autom4te.cache
+ -rm -f config.*
+ -rm -f depcomp
+ -rm -f install-sh
+ -rm -f ltmain.sh
+ -rm -f py-compile
+ -rm -f missing
+ -rm -f volk_config.h.in
+ -rm -f aclocal.m4
+ -rm -f Makefile.in
+ -rm -f config/lt*
+ -rm -f config/libtool*
+ -rm -f apps/Makefile.in
+ -rm -f config/Makefile.in
+ -rm -f data/Makefile.in
+ -rm -f doc/Makefile.in
+ -rm -f include/Makefile.in
+ -rm -f lib/Makefile.in
+ -rm -f python/Makefile.in
+ -rm -f configure \ No newline at end of file