summaryrefslogtreecommitdiff
path: root/usrp/firmware/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'usrp/firmware/include/Makefile.am')
-rw-r--r--usrp/firmware/include/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/usrp/firmware/include/Makefile.am b/usrp/firmware/include/Makefile.am
new file mode 100644
index 000000000..7f58d19fe
--- /dev/null
+++ b/usrp/firmware/include/Makefile.am
@@ -0,0 +1,59 @@
+#
+# Copyright 2003 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+include_HEADERS = \
+ usrp_i2c_addr.h \
+ usrp_spi_defs.h
+
+
+noinst_HEADERS = \
+ delay.h \
+ fpga_regs_common.h \
+ fpga_regs_common.v \
+ fpga_regs_standard.h \
+ fpga_regs_standard.v \
+ fpga_regs0.h \
+ fx2regs.h \
+ fx2utils.h \
+ i2c.h \
+ isr.h \
+ syncdelay.h \
+ timer.h \
+ usb_common.h \
+ usb_descriptors.h \
+ usb_requests.h \
+ usrp_commands.h \
+ usrp_config.h \
+ usrp_ids.h \
+ usrp_interfaces.h
+
+
+CODE_GENERATOR = \
+ generate_regs.py
+
+EXTRA_DIST = \
+ $(CODE_GENERATOR)
+
+fpga_regs_common.v: fpga_regs_common.h generate_regs.py
+ PYTHONPATH=$(top_srcdir)/usrp/firmware/include $(srcdir)/generate_regs.py $< $@
+
+fpga_regs_standard.v: fpga_regs_standard.h generate_regs.py
+ PYTHONPATH=$(top_srcdir)/usrp/firmware/include $(srcdir)/generate_regs.py $< $@