summaryrefslogtreecommitdiff
path: root/gruel/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gruel/src/lib/CMakeLists.txt')
-rw-r--r--gruel/src/lib/CMakeLists.txt46
1 files changed, 23 insertions, 23 deletions
diff --git a/gruel/src/lib/CMakeLists.txt b/gruel/src/lib/CMakeLists.txt
index d078e52f9..b54e644bc 100644
--- a/gruel/src/lib/CMakeLists.txt
+++ b/gruel/src/lib/CMakeLists.txt
@@ -20,13 +20,13 @@
########################################################################
# Include subdirs rather to populate to the sources lists.
########################################################################
-INCLUDE(GrMiscUtils)
-INCLUDE(CheckCXXSourceCompiles)
+include(GrMiscUtils)
+include(CheckCXXSourceCompiles)
GR_CHECK_HDR_N_DEF(signal.h HAVE_SIGNAL_H)
GR_CHECK_HDR_N_DEF(sched.h HAVE_SCHED_H)
-SET(CMAKE_REQUIRED_LIBRARIES -lpthread)
+set(CMAKE_REQUIRED_LIBRARIES -lpthread)
CHECK_CXX_SOURCE_COMPILES("
#include <signal.h>
int main(){pthread_sigmask(0, 0, 0); return 0;}
@@ -34,7 +34,7 @@ CHECK_CXX_SOURCE_COMPILES("
)
GR_ADD_COND_DEF(HAVE_PTHREAD_SIGMASK)
-SET(CMAKE_REQUIRED_LIBRARIES -lpthread)
+set(CMAKE_REQUIRED_LIBRARIES -lpthread)
CHECK_CXX_SOURCE_COMPILES("
#include <pthread.h>
int main(){
@@ -64,28 +64,28 @@ GR_INCLUDE_SUBDIRECTORY(pmt)
########################################################################
# Setup the include and linker paths
########################################################################
-INCLUDE_DIRECTORIES(${GRUEL_INCLUDE_DIRS})
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${GRUEL_INCLUDE_DIRS})
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
-LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+include_directories(${Boost_INCLUDE_DIRS})
+link_directories(${Boost_LIBRARY_DIRS})
########################################################################
# Setup library
########################################################################
-LIST(APPEND gruel_sources
+list(APPEND gruel_sources
realtime.cc
sys_pri.cc
thread_body_wrapper.cc
thread_group.cc
)
-ADD_LIBRARY(gruel SHARED ${gruel_sources})
-TARGET_LINK_LIBRARIES(gruel ${Boost_LIBRARIES})
-SET_TARGET_PROPERTIES(gruel PROPERTIES DEFINE_SYMBOL "gruel_EXPORTS")
-SET_TARGET_PROPERTIES(gruel PROPERTIES SOVERSION ${LIBVER})
+add_library(gruel SHARED ${gruel_sources})
+target_link_libraries(gruel ${Boost_LIBRARIES})
+set_target_properties(gruel PROPERTIES DEFINE_SYMBOL "gruel_EXPORTS")
+set_target_properties(gruel PROPERTIES SOVERSION ${LIBVER})
-INSTALL(TARGETS gruel
+install(TARGETS gruel
LIBRARY DESTINATION ${GR_LIBRARY_DIR} COMPONENT "gruel_runtime" # .so/.dylib file
ARCHIVE DESTINATION ${GR_LIBRARY_DIR} COMPONENT "gruel_devel" # .lib file
RUNTIME DESTINATION ${GR_RUNTIME_DIR} COMPONENT "gruel_runtime" # .dll file
@@ -95,16 +95,16 @@ INSTALL(TARGETS gruel
# Setup tests
# Set the test environment so the build libs will be found under MSVC.
########################################################################
-IF(ENABLE_TESTING)
+if(ENABLE_TESTING)
-INCLUDE_DIRECTORIES(${CPPUNIT_INCLUDE_DIRS})
-LINK_DIRECTORIES(${CPPUNIT_LIBRARY_DIRS})
+include_directories(${CPPUNIT_INCLUDE_DIRS})
+link_directories(${CPPUNIT_LIBRARY_DIRS})
-INCLUDE(GrTest)
-SET(GR_TEST_TARGET_DEPS gruel)
-LIST(APPEND test_gruel_sources test_gruel.cc)
-ADD_EXECUTABLE(test_gruel ${test_gruel_sources})
-TARGET_LINK_LIBRARIES(test_gruel gruel ${CPPUNIT_LIBRARIES})
+include(GrTest)
+set(GR_TEST_TARGET_DEPS gruel)
+list(APPEND test_gruel_sources test_gruel.cc)
+add_executable(test_gruel ${test_gruel_sources})
+target_link_libraries(test_gruel gruel ${CPPUNIT_LIBRARIES})
GR_ADD_TEST(gruel-test test_gruel)
-ENDIF(ENABLE_TESTING)
+endif(ENABLE_TESTING)