summaryrefslogtreecommitdiff
path: root/grc/src/platforms/base/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'grc/src/platforms/base/Makefile.am')
-rw-r--r--grc/src/platforms/base/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/grc/src/platforms/base/Makefile.am b/grc/src/platforms/base/Makefile.am
index fbfc87e00..4cc08b036 100644
--- a/grc/src/platforms/base/Makefile.am
+++ b/grc/src/platforms/base/Makefile.am
@@ -34,15 +34,13 @@ ourpython_PYTHON = \
Port.py \
__init__.py
-BUILT_SOURCES = Constants.py
-
-Constants.py: Makefile $(srcdir)/Constants.py.in
- sed \
+Constants.py: Makefile Constants.py.in
+ $(SED) \
-e 's|@PACKAGE[@]|$(PACKAGE)|g' \
-e 's|@VERSION[@]|$(VERSION)|g' \
-e 's|@datadir[@]|$(grc_base_data_dir)|g' \
- $(srcdir)/Constants.py.in > $@
+ $(srcdir)/$@.in > $@
EXTRA_DIST = $(srcdir)/Constants.py.in
-MOSTLYCLEANFILES = $(BUILT_SOURCES)
+MOSTLYCLEANFILES = Constants.py