summaryrefslogtreecommitdiff
path: root/grc/src/platforms/base/Makefile.am
diff options
context:
space:
mode:
authorjblum2008-10-07 18:32:29 +0000
committerjblum2008-10-07 18:32:29 +0000
commite0feca2c67788dffeff9a21fb047a8965658e528 (patch)
tree8a56fc4fc1df3c3f3ebdf64e019539f9bc9273af /grc/src/platforms/base/Makefile.am
parent28aecb1ad5ce542a7611bb5a38001a32097bfb73 (diff)
downloadgnuradio-e0feca2c67788dffeff9a21fb047a8965658e528.tar.gz
gnuradio-e0feca2c67788dffeff9a21fb047a8965658e528.tar.bz2
gnuradio-e0feca2c67788dffeff9a21fb047a8965658e528.zip
re-enable grc, passes distcheck
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@9723 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'grc/src/platforms/base/Makefile.am')
-rw-r--r--grc/src/platforms/base/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/grc/src/platforms/base/Makefile.am b/grc/src/platforms/base/Makefile.am
index fbfc87e00..4cc08b036 100644
--- a/grc/src/platforms/base/Makefile.am
+++ b/grc/src/platforms/base/Makefile.am
@@ -34,15 +34,13 @@ ourpython_PYTHON = \
Port.py \
__init__.py
-BUILT_SOURCES = Constants.py
-
-Constants.py: Makefile $(srcdir)/Constants.py.in
- sed \
+Constants.py: Makefile Constants.py.in
+ $(SED) \
-e 's|@PACKAGE[@]|$(PACKAGE)|g' \
-e 's|@VERSION[@]|$(VERSION)|g' \
-e 's|@datadir[@]|$(grc_base_data_dir)|g' \
- $(srcdir)/Constants.py.in > $@
+ $(srcdir)/$@.in > $@
EXTRA_DIST = $(srcdir)/Constants.py.in
-MOSTLYCLEANFILES = $(BUILT_SOURCES)
+MOSTLYCLEANFILES = Constants.py