summaryrefslogtreecommitdiff
path: root/gr-wxgui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-wxgui/CMakeLists.txt')
-rw-r--r--gr-wxgui/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/gr-wxgui/CMakeLists.txt b/gr-wxgui/CMakeLists.txt
index 5beb39f5e..7afae785a 100644
--- a/gr-wxgui/CMakeLists.txt
+++ b/gr-wxgui/CMakeLists.txt
@@ -29,11 +29,17 @@ GR_PYTHON_CHECK_MODULE("numpy" numpy True
# Register component
########################################################################
include(GrComponent)
+if(NOT CMAKE_CROSSCOMPILING)
+ set(wxgui_python_deps
+ NUMPY_FOUND
+ WX_FOUND
+ )
+endif(NOT CMAKE_CROSSCOMPILING)
+
GR_REGISTER_COMPONENT("gr-wxgui" ENABLE_GR_WXGUI
ENABLE_GR_CORE
ENABLE_PYTHON
- NUMPY_FOUND
- WX_FOUND
+ ${wxgui_python_deps}
)
########################################################################