summaryrefslogtreecommitdiff
path: root/gr-wxgui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-wxgui/CMakeLists.txt')
-rw-r--r--gr-wxgui/CMakeLists.txt83
1 files changed, 83 insertions, 0 deletions
diff --git a/gr-wxgui/CMakeLists.txt b/gr-wxgui/CMakeLists.txt
new file mode 100644
index 000000000..7002ce91b
--- /dev/null
+++ b/gr-wxgui/CMakeLists.txt
@@ -0,0 +1,83 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup dependencies
+########################################################################
+INCLUDE(GrPython)
+
+GR_PYTHON_CHECK_MODULE("wx >= 2.8" wx "wx.version().split()[0] >= '2.8'" WX_FOUND)
+GR_PYTHON_CHECK_MODULE("numpy" numpy True NUMPY_FOUND)
+
+########################################################################
+# Register component
+########################################################################
+INCLUDE(GrComponent)
+GR_REGISTER_COMPONENT("gr-wxgui" ENABLE_WXGUI
+ ENABLE_GR_CORE_
+ ENABLE_PYTHON_
+ NUMPY_FOUND
+ WX_FOUND
+)
+
+########################################################################
+# Begin conditional configuration
+########################################################################
+IF(ENABLE_WXGUI)
+
+########################################################################
+# Setup CPack components
+########################################################################
+INCLUDE(GrPackage)
+CPACK_COMPONENT("wxgui"
+ DISPLAY_NAME "WxGUI"
+ DESCRIPTION "Wx GUI plotter widgets and grc wrappers"
+ DEPENDS "core_python"
+)
+
+########################################################################
+# Create Pkg Config File
+########################################################################
+CONFIGURE_FILE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/gr-wxgui.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/gr-wxgui.pc
+@ONLY)
+
+INSTALL(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/gr-wxgui.pc
+ DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
+ COMPONENT "wxgui"
+)
+
+########################################################################
+# Install the conf file
+########################################################################
+INSTALL(
+ FILES ${CMAKE_CURRENT_SOURCE_DIR}/gr-wxgui.conf
+ DESTINATION ${GR_PKG_CONF_DIR}
+ COMPONENT "wxgui"
+)
+
+########################################################################
+# Add subdirectories
+########################################################################
+ADD_SUBDIRECTORY(grc)
+ADD_SUBDIRECTORY(src/python)
+
+ENDIF(ENABLE_WXGUI)