summaryrefslogtreecommitdiff
path: root/gr-video-sdl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-video-sdl/CMakeLists.txt')
-rw-r--r--gr-video-sdl/CMakeLists.txt99
1 files changed, 99 insertions, 0 deletions
diff --git a/gr-video-sdl/CMakeLists.txt b/gr-video-sdl/CMakeLists.txt
new file mode 100644
index 000000000..a5d4f1b49
--- /dev/null
+++ b/gr-video-sdl/CMakeLists.txt
@@ -0,0 +1,99 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup dependencies
+########################################################################
+INCLUDE(GrBoost)
+
+FIND_PACKAGE(SDL)
+
+########################################################################
+# Register component
+########################################################################
+INCLUDE(GrComponent)
+GR_REGISTER_COMPONENT("gr-video-sdl" ENABLE_GR_VIDEO_SDL
+ SDL_FOUND
+ Boost_FOUND
+ ENABLE_GR_CORE_
+)
+
+GR_SET_GLOBAL(GR_VIDEO_SDL_INCLUDE_DIRS
+ ${CMAKE_CURRENT_SOURCE_DIR}/src
+)
+
+########################################################################
+# Begin conditional configuration
+########################################################################
+IF(ENABLE_GR_VIDEO_SDL)
+
+########################################################################
+# Setup CPack components
+########################################################################
+INCLUDE(GrPackage)
+CPACK_SET(CPACK_COMPONENT_GROUP_VIDEO_SDL_DESCRIPTION "The GNU Radio Video SDL Blocks")
+
+CPACK_COMPONENT("video_sdl_runtime"
+ GROUP "Video SDL"
+ DISPLAY_NAME "Runtime"
+ DESCRIPTION "Runtime"
+ DEPENDS "core_runtime"
+)
+
+CPACK_COMPONENT("video_sdl_devel"
+ GROUP "Video SDL"
+ DISPLAY_NAME "Development"
+ DESCRIPTION "C++ headers, package config, import libraries"
+ DEPENDS "core_devel"
+)
+
+CPACK_COMPONENT("video_sdl_python"
+ GROUP "Video SDL"
+ DISPLAY_NAME "Python"
+ DESCRIPTION "Python modules for runtime; GRC xml files"
+ DEPENDS "core_python;video_sdl_runtime"
+)
+
+CPACK_COMPONENT("video_sdl_swig"
+ GROUP "Video SDL"
+ DISPLAY_NAME "SWIG"
+ DESCRIPTION "SWIG development .i files"
+ DEPENDS "core_swig;video_sdl_python;video_sdl_devel"
+)
+
+########################################################################
+# Add subdirectories
+########################################################################
+ADD_SUBDIRECTORY(src)
+
+########################################################################
+# Create Pkg Config File
+########################################################################
+CONFIGURE_FILE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/gnuradio-video-sdl.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-video-sdl.pc
+@ONLY)
+
+INSTALL(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-video-sdl.pc
+ DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
+ COMPONENT "video_sdl_devel"
+)
+
+ENDIF(ENABLE_GR_VIDEO_SDL)