summaryrefslogtreecommitdiff
path: root/gr-qtgui/python/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-qtgui/python/CMakeLists.txt')
-rw-r--r--gr-qtgui/python/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/gr-qtgui/python/CMakeLists.txt b/gr-qtgui/python/CMakeLists.txt
index e80fa6b75..e61b54f08 100644
--- a/gr-qtgui/python/CMakeLists.txt
+++ b/gr-qtgui/python/CMakeLists.txt
@@ -18,7 +18,7 @@
# Boston, MA 02110-1301, USA.
########################################################################
-INCLUDE(GrPython)
+include(GrPython)
GR_PYTHON_INSTALL(
FILES __init__.py
@@ -29,18 +29,18 @@ GR_PYTHON_INSTALL(
########################################################################
# Handle the unit tests
########################################################################
-IF(ENABLE_TESTING)
-INCLUDE(GrTest)
-FILE(GLOB py_qa_test_files "qa_*.py")
-FOREACH(py_qa_test_file ${py_qa_test_files})
- GET_FILENAME_COMPONENT(py_qa_test_name ${py_qa_test_file} NAME_WE)
- SET(GR_TEST_PYTHON_DIRS
+if(ENABLE_TESTING)
+include(GrTest)
+file(GLOB py_qa_test_files "qa_*.py")
+foreach(py_qa_test_file ${py_qa_test_files})
+ get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
+ set(GR_TEST_PYTHON_DIRS
${CMAKE_BINARY_DIR}/gnuradio-core/src/python
${CMAKE_BINARY_DIR}/gnuradio-core/src/lib/swig
${CMAKE_BINARY_DIR}/gr-qtgui/python
${CMAKE_BINARY_DIR}/gr-qtgui/swig
)
- SET(GR_TEST_TARGET_DEPS gruel gnuradio-core gnuradio-qtgui)
+ set(GR_TEST_TARGET_DEPS gruel gnuradio-core gnuradio-qtgui)
GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${py_qa_test_file})
-ENDFOREACH(py_qa_test_file)
-ENDIF(ENABLE_TESTING)
+endforeach(py_qa_test_file)
+endif(ENABLE_TESTING)