summaryrefslogtreecommitdiff
path: root/gr-fft/python/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-fft/python/CMakeLists.txt')
-rw-r--r--gr-fft/python/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/gr-fft/python/CMakeLists.txt b/gr-fft/python/CMakeLists.txt
index 1e354d7a2..3b328780f 100644
--- a/gr-fft/python/CMakeLists.txt
+++ b/gr-fft/python/CMakeLists.txt
@@ -31,17 +31,17 @@ GR_PYTHON_INSTALL(
# Handle the unit tests
########################################################################
if(ENABLE_TESTING)
+
+list(APPEND GR_TEST_PYTHON_DIRS
+ ${CMAKE_BINARY_DIR}/gr-fft/python
+ ${CMAKE_BINARY_DIR}/gr-fft/swig
+)
+list(APPEND GR_TEST_TARGET_DEPS gnuradio-fft)
+
include(GrTest)
file(GLOB py_qa_test_files "qa_*.py")
foreach(py_qa_test_file ${py_qa_test_files})
get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
- set(GR_TEST_PYTHON_DIRS
- ${CMAKE_BINARY_DIR}/gnuradio-core/src/python
- ${CMAKE_BINARY_DIR}/gnuradio-core/src/lib/swig
- ${CMAKE_BINARY_DIR}/gr-fft/python
- ${CMAKE_BINARY_DIR}/gr-fft/swig
- )
- list(APPEND GR_TEST_TARGET_DEPS gnuradio-fft)
GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${PYTHON_DASH_B} ${py_qa_test_file})
endforeach(py_qa_test_file)
endif(ENABLE_TESTING)