summaryrefslogtreecommitdiff
path: root/gr-comedi/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-comedi/src/CMakeLists.txt')
-rw-r--r--gr-comedi/src/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/gr-comedi/src/CMakeLists.txt b/gr-comedi/src/CMakeLists.txt
index 0ef429a7d..91bbf9212 100644
--- a/gr-comedi/src/CMakeLists.txt
+++ b/gr-comedi/src/CMakeLists.txt
@@ -100,16 +100,16 @@ endif(ENABLE_PYTHON)
# Handle the unit tests
########################################################################
if(ENABLE_TESTING AND ENABLE_PYTHON)
+
+list(APPEND GR_TEST_PYTHON_DIRS
+ ${CMAKE_BINARY_DIR}/gr-comedi/src
+)
+list(APPEND GR_TEST_TARGET_DEPS gnuradio-comedi)
+
include(GrTest)
file(GLOB py_qa_test_files "qa_*.py")
foreach(py_qa_test_file ${py_qa_test_files})
get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
- set(GR_TEST_PYTHON_DIRS
- ${CMAKE_BINARY_DIR}/gnuradio-core/src/python
- ${CMAKE_BINARY_DIR}/gnuradio-core/src/lib/swig
- ${CMAKE_BINARY_DIR}/gr-comedi/src
- )
- list(APPEND GR_TEST_TARGET_DEPS gnuradio-comedi)
GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${PYTHON_DASH_B} ${py_qa_test_file})
endforeach(py_qa_test_file)
endif(ENABLE_TESTING AND ENABLE_PYTHON)