summaryrefslogtreecommitdiff
path: root/gr-audio-oss/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-audio-oss/src/Makefile.am')
-rw-r--r--gr-audio-oss/src/Makefile.am22
1 files changed, 9 insertions, 13 deletions
diff --git a/gr-audio-oss/src/Makefile.am b/gr-audio-oss/src/Makefile.am
index 628c9fd93..2468958b2 100644
--- a/gr-audio-oss/src/Makefile.am
+++ b/gr-audio-oss/src/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2008,2009,2010 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -20,10 +20,14 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
+
+TESTS =
+EXTRA_DIST += run_tests.in
+DISTCLEANFILES += run_tests
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
-EXTRA_DIST = run_tests.in
# C/C++ headers get installed in ${prefix}/include/gnuradio
grinclude_HEADERS = \
@@ -44,12 +48,8 @@ libgnuradio_audio_oss_la_LIBADD = \
libgnuradio_audio_oss_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
-if PYTHON
###################################
-# SWIG Python interface and library
-TESTS = run_tests
-DISTCLEANFILES = run_tests
-
+# SWIG interface and library
TOP_SWIG_IFILES = \
audio_oss.i
@@ -64,11 +64,7 @@ audio_oss_pythondir_category = \
audio_oss_la_swig_libadd = \
libgnuradio-audio-oss.la
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
+if PYTHON
+TESTS += run_tests
endif