summaryrefslogtreecommitdiff
path: root/gr-audio-alsa/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-audio-alsa/src/Makefile.am')
-rw-r--r--gr-audio-alsa/src/Makefile.am38
1 files changed, 22 insertions, 16 deletions
diff --git a/gr-audio-alsa/src/Makefile.am b/gr-audio-alsa/src/Makefile.am
index ed92cc197..330158aa5 100644
--- a/gr-audio-alsa/src/Makefile.am
+++ b/gr-audio-alsa/src/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2004,2008,2009 Free Software Foundation, Inc.
+# Copyright 2004,2008,2009,2010 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -20,8 +20,11 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
-EXTRA_DIST = run_tests.in
+TESTS =
+EXTRA_DIST += run_tests.in run_guile_tests.in
+DISTCLEANFILES += run_tests run_guile_tests
# C/C++ headers get installed in ${prefix}/include/gnuradio
grinclude_HEADERS = \
@@ -32,12 +35,16 @@ noinst_HEADERS = \
gri_alsa.h
noinst_PYTHON = \
- qa_alsa.py
+ qa_audio_alsa.py
+
+noinst_GUILE = \
+ audio_alsa.test
+
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
-###################################
-# ALSA library, including OS interface, sink, and source
+# ------------------------------------------------------------------------
+# ALSA C++ library, including OS interface, sink, and source
lib_LTLIBRARIES = libgnuradio-audio-alsa.la
@@ -52,11 +59,9 @@ libgnuradio_audio_alsa_la_LIBADD = \
libgnuradio_audio_alsa_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
-if PYTHON
-###################################
-# SWIG Python interface and library
-TESTS = run_tests
-DISTCLEANFILES = run_tests
+
+# ------------------------------------------------------------------------
+# SWIG generated bindings
TOP_SWIG_IFILES = \
audio_alsa.i
@@ -72,11 +77,12 @@ audio_alsa_pythondir_category = \
audio_alsa_la_swig_libadd = \
libgnuradio-audio-alsa.la
-include $(top_srcdir)/Makefile.swig
+if PYTHON
+TESTS += run_tests
+endif
+
+if GUILE
+TESTS += run_guile_tests
+endif
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
-endif \ No newline at end of file