summaryrefslogtreecommitdiff
path: root/gr-analog/swig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-analog/swig/CMakeLists.txt')
-rw-r--r--gr-analog/swig/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/gr-analog/swig/CMakeLists.txt b/gr-analog/swig/CMakeLists.txt
new file mode 100644
index 000000000..e3fbbe73f
--- /dev/null
+++ b/gr-analog/swig/CMakeLists.txt
@@ -0,0 +1,51 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup swig generation
+########################################################################
+include(GrPython)
+include(GrSwig)
+
+set(GR_SWIG_INCLUDE_DIRS
+ ${GR_ANALOG_INCLUDE_DIRS}
+ ${GR_FILTER_INCLUDE_DIRS}
+ ${GNURADIO_CORE_SWIG_INCLUDE_DIRS}
+)
+
+set(GR_SWIG_DOC_FILE ${CMAKE_CURRENT_BINARY_DIR}/analog_swig_doc.i)
+set(GR_SWIG_DOC_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/../lib)
+
+set(GR_SWIG_LIBRARIES gnuradio-analog gnuradio-filter)
+
+GR_SWIG_MAKE(analog_swig analog_swig.i)
+
+GR_SWIG_INSTALL(
+ TARGETS analog_swig
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/analog
+ COMPONENT "analog_python"
+)
+
+install(
+ FILES
+ analog_swig.i
+ ${CMAKE_CURRENT_BINARY_DIR}/analog_swig_doc.i
+ DESTINATION ${GR_INCLUDE_DIR}/gnuradio/swig
+ COMPONENT "analog_swig"
+)