summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/io/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gnuradio-core/src/lib/io/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/io/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnuradio-core/src/lib/io/Makefile.am b/gnuradio-core/src/lib/io/Makefile.am
index c52554645..0ab9ac135 100644
--- a/gnuradio-core/src/lib/io/Makefile.am
+++ b/gnuradio-core/src/lib/io/Makefile.am
@@ -113,3 +113,17 @@ swiginclude_HEADERS = \
gr_wavfile_source.i \
gr_wavfile_sink.i
endif
+
+# Produce a list of the file names with the .cc stripped off
+files = $(foreach HFILE,$(libio_la_SOURCES), $(patsubst %.cc,%,$(HFILE)))
+
+# All .lo files depend on the .i file of the same name
+define template
+-include $(DEPDIR)/$(1).d
+$(DEPDIR)/$(1).d:
+ @echo "$(1).lo: \\" > $(DEPDIR)/$(1).d
+ @cat ../swig/guile/gnuradio_core_io.Std | sed -e '1d;' >> $(DEPDIR)/$(1).d
+endef
+
+# Generate all the dependencies at runtime
+$(foreach prog,$(files),$(eval $(call template,$(prog))))