summaryrefslogtreecommitdiff
path: root/gnuradio-core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gnuradio-core/Makefile.am')
-rw-r--r--gnuradio-core/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnuradio-core/Makefile.am b/gnuradio-core/Makefile.am
new file mode 100644
index 000000000..b4b619b8b
--- /dev/null
+++ b/gnuradio-core/Makefile.am
@@ -0,0 +1,36 @@
+#
+# Copyright 2001,2006 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+EXTRA_DIST = \
+ gnuradio-core.conf \
+ gnuradio-core.pc.in \
+ README.hacking \
+ README-win32-mingw-short.txt
+
+SUBDIRS = src doc
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gnuradio-core.pc
+
+etcdir = $(sysconfdir)/gnuradio/conf.d
+etc_DATA = gnuradio-core.conf