summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/build-all.sh2
-rw-r--r--debian/control111
-rwxr-xr-xdebian/gen-install-files.sh60
-rw-r--r--debian/gnuradio-radar-mono-firmware.install3
-rw-r--r--debian/gnuradio-sounder-firmware.install3
-rwxr-xr-xdebian/rules2
6 files changed, 177 insertions, 4 deletions
diff --git a/debian/build-all.sh b/debian/build-all.sh
index 5e0c26937..0b3ec2460 100755
--- a/debian/build-all.sh
+++ b/debian/build-all.sh
@@ -7,4 +7,6 @@ svn-buildpackage \
-us \
-rfakeroot
+cd ../build-area
+dpkg-scanpackages . /dev/null | gzip -9c > Packages.gz
diff --git a/debian/control b/debian/control
index 3c3568eb3..a38fcd3f9 100644
--- a/debian/control
+++ b/debian/control
@@ -90,8 +90,6 @@ Description: Software Defined Radio
Package: python-gnuradio-core
Architecture: any
Depends: ${python:Depends}, libgnuradio-core0c2a, python-numpy
-Conflicts: python-gnuradio
-Replaces: python-gnuradio
Provides: ${python:Provides}
Section: python
XB-Python-Version: ${python:Versions}
@@ -103,6 +101,7 @@ Package: python-gnuradio-audio-alsa
Architecture: any
Depends: ${python:Depends}, python-gnuradio-core, libasound2
Section: python
+Provides: python-gnuradio-audio
XB-Python-Version: ${python:Versions}
Description: Python bindings for GNU Radio ALSA audio driver
This package provides the Python interface to the GNU Radio ALSA
@@ -115,6 +114,7 @@ Depends: libusb-0.1-4
Conflicts: libusrp0
Replaces: libusrp0
Suggests: usrp-doc
+Recommends: usrp-firmware
Description: Client side library for the USRP
The Universal Software Radio Peripheral (USRP) is an USB-connected,
low-cost and open board. It features four high-speed analog-to-digital
@@ -224,6 +224,7 @@ Package: python-gnuradio-audio-jack
Architecture: any
Depends: ${python:Depends}, python-gnuradio-core, libjack0.100.0-0
Section: python
+Provides: python-gnuradio-audio
XB-Python-Version: ${python:Versions}
Description: GNU Radio Python JACK Audio Driver
This package provides the Python interface to the GNU Radio driver
@@ -233,6 +234,7 @@ Package: python-gnuradio-audio-oss
Architecture: any
Depends: ${python:Depends}, python-gnuradio-core
Section: python
+Provides: python-gnuradio-audio
XB-Python-Version: ${python:Versions}
Description: GNU Radio Python OSS Audio Driver
This package provides the Python interface to the GNU Radio driver
@@ -242,6 +244,7 @@ Package: python-gnuradio-audio-portaudio
Architecture: any
Depends: ${python:Depends}, python-gnuradio-core, libportaudio2
Section: python
+Provides: python-gnuradio-audio
XB-Python-Version: ${python:Versions}
Description: GNU Radio Python PortAudio Driver
This package provides the Python interface to the GNU Radio driver
@@ -288,6 +291,108 @@ Architecture: any
Depends: ${python:Depends}, python-gnuradio-core, libsdl1.2debian
Section: python
XB-Python-Version: ${python:Versions}
+Description: GNU SDL Interface Library
+ This package provides an interface to the SDL rendering library
+ for GNU Radio.
+
+Package: python-gnuradio-utils
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-usrp, python-gnuradio-wxgui
+Section: python
+XB-Python-Version: ${python:Versions}
Description: GNU Radio Trellis-Coded Modulation library
- This package provides an implementation of trellis-coded modulation
+ This package provides commonly used utilities for GNU Radio
+
+Package: gnuradio-examples
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp, python-gnuradio-wxgui, python-gnuradio-audio
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio Example Programs
+ This package provides examples of GNU Radio usage using Python
+
+Package: gnuradio-pager
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio FLEX Pager Decoder
+ This package provides a decoder for the FLEX paging protocol for GNU Radio
+
+Package: gnuradio-radio-astronomy
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp, python-gnuradio-wxgui
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio Radio Astronomy Applications
+ This package provides radio astronomy applications for GNU Radio
+
+Package: gnuradio-radar-mono
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp
+Recommends: gnuradio-radar-mono-firmware
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio Mono-static Radar Application
+ This package provides a mono-static radar application for GNU Radio
+
+Package: gnuradio-radar-mono-firmware
+Section: contrib/comm
+Architecture: all
+Description: GNU Radio Mono-static Radar Firmware
+ This package provides a mono-static radar application for GNU Radio
+ .
+ This package contains the FPGA bitstrings for the USRP, which require
+ non-free tools to build.
+
+Package: gnuradio-sounder
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp
+Recommends: gnuradio-sounder-firmware
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio Channel Sounder Application
+ This package provides an RF channel sounder application for GNU Radio
+
+Package: gnuradio-sounder-firmware
+Section: contrib/comm
+Architecture: all
+Description: GNU Radio Channel Sounder Application
+ This package provides an RF channel sounder application for GNU Radio
+ .
+ This package contains the FPGA bitstrings for the USRP, which require
+ non-free tools to build.
+
+Package: python-gnuradio
+Section: python
+Architecture: all
+Depends: python-gnuradio-atsc, python-gnuradio-audio-alsa, python-gnuradio-audio-jack, python-gnuradio-audio-oss, python-gnuradio-audio-portaudio, python-gnuradio-comedi, python-gnuradio-core, python-gnuradio-cvsd-vocoder, python-gnuradio-gsm-fr-vocoder, python-gnuradio-trellis, python-gnuradio-usrp, python-gnuradio-utils, python-gnuradio-video-sdl, python-gnuradio-wxgui
+Description: Python Libraries for GNU Radio Components
+ This is a virtual package that depends upon all the Python components
for GNU Radio.
+
+Package: gnuradio
+Section: comm
+Architecture: all
+Depends: gnuradio-doc, gnuradio-examples, python-gnuradio, gnuradio-pager, gnuradio-radar-mono, gnuradio-radio-astronomy, gnuradio-sounder
+Suggests: usrp
+Descripton: GNU Software Defined Radio
+ This is a virtual package that depends the entire GNU Radio collection of
+ components. If you are using a USRP, you should also install the usrp package.
+
+Package: gnuradio-dev
+Section: libdevel
+Architecture: all
+Depends: libgnuradio-core0-dev, libgnuradio-omnithread0-dev, libmblock0-dev, libpmt0-dev
+Description: Development headers for GNU Radio C++ development
+ This is a virtual package that depends on all the development header packages
+ for the various GNU Radio components. It is only needed if you intend to develop
+ custom GNU Radio signal processing blocks in C++.
+
+Package: usrp
+Section: comm
+Architecture: all
+Depends: libusrp0c2a, python-usrp, usrp-doc
+Description: The Univeral Software Radio Peripheral
+ This is a virtual package that depends on the entire USRP software collection. You will
+ still need to install package usrp-firmware, in contrib/comm, however.
diff --git a/debian/gen-install-files.sh b/debian/gen-install-files.sh
index 1eaabd213..b7e9f91a1 100755
--- a/debian/gen-install-files.sh
+++ b/debian/gen-install-files.sh
@@ -44,6 +44,7 @@ $EXTRACT gnuradio-core/src/python/gnuradio/blksimpl/Makefile grblkspython_PYTHON
$EXTRACT gnuradio-core/src/python/gnuradio/blksimpl2/Makefile grblkspython_PYTHON >>$NAME
$EXTRACT gnuradio-core/src/python/gnuradio/gru/Makefile grblkspython_PYTHON >>$NAME
$EXTRACT gnuradio-core/src/python/gnuradio/gruimpl/Makefile grupython_PYTHON >>$NAME
+$EXTRACT gnuradio-core/src/python/gnuradio/vocoder/Makefile grvocoderpython_PYTHON >>$NAME
# libusrp0-dev
NAME=debian/libusrp0-dev.install
@@ -93,6 +94,7 @@ $EXTRACT gr-atsc/src/lib/Makefile ourpython_PYTHON >>$NAME
$EXTRACT gr-atsc/src/lib/Makefile ourlib_LTLIBRARIES >>$NAME
$EXTRACT gr-atsc/src/lib/Makefile ourlib_LTLIBRARIES | \
sed -e 's/\.la$/.so/' >>$NAME
+$EXTRACT gr-atsc/src/python/Makefile ourdata_DATA >>$NAME
# python-gnuradio-audio-alsa
NAME=debian/python-gnuradio-audio-alsa.install
@@ -176,6 +178,8 @@ $EXTRACT gr-trellis/src/lib/Makefile ourpython_PYTHON >>$NAME
$EXTRACT gr-trellis/src/lib/Makefile ourlib_LTLIBRARIES >>$NAME
$EXTRACT gr-trellis/src/lib/Makefile ourlib_LTLIBRARIES | \
sed -e 's/\.la$/.so/' >>$NAME
+$EXTRACT gr-trellis/src/examples/Makefile ourdata_DATA >>$NAME
+$EXTRACT gr-trellis/src/examples/fsm_files/Makefile ourdata_DATA >>$NAME
# python-gnuradio-video-sdl
NAME=debian/python-gnuradio-video-sdl.install
@@ -185,3 +189,59 @@ $EXTRACT gr-video-sdl/src/Makefile ourpython_PYTHON >>$NAME
$EXTRACT gr-video-sdl/src/Makefile ourlib_LTLIBRARIES >>$NAME
$EXTRACT gr-video-sdl/src/Makefile ourlib_LTLIBRARIES | \
sed -e 's/\.la$/.so/' >>$NAME
+
+# python-gnuradio-video-sdl
+NAME=debian/python-gnuradio-utils.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-utils/src/python/Makefile bin_SCRIPTS >>$NAME
+
+# gnuradio-examples
+NAME=debian/gnuradio-examples.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gnuradio-examples/python/apps/hf_explorer/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/apps/hf_radio/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/audio/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/digital/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/digital_voice/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/multi-antenna/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/multi_usrp/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/ofdm/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/usrp/Makefile ourdata_DATA >>$NAME
+
+# gnuradio-pager
+NAME=debian/gnuradio-pager.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-pager/src/Makefile bin_SCRIPTS >>$NAME
+$EXTRACT gr-pager/src/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-pager/src/Makefile ourlib_LTLIBRARIES >>$NAME
+$EXTRACT gr-pager/src/Makefile ourlib_LTLIBRARIES |
+ sed -e 's/\.la$/.so/' >>$NAME
+
+# gnuradio-radio-astronomy
+NAME=debian/gnuradio-radio-astronomy.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-radio-astronomy/src/python/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-radio-astronomy/src/python/Makefile wxguipython_PYTHON >>$NAME
+$EXTRACT gr-radio-astronomy/src/python/Makefile bin_SCRIPTS >>$NAME
+$EXTRACT gr-radio-astronomy/src/lib/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-radio-astronomy/src/lib/Makefile ourlib_LTLIBRARIES >>$NAME
+$EXTRACT gr-radio-astronomy/src/lib/Makefile ourlib_LTLIBRARIES |
+ sed -e 's/\.la$/.so/' >>$NAME
+
+# gnuradio-radar-mono
+NAME=debian/gnuradio-radar-mono.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-radar-mono/src/python/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-radar-mono/src/python/Makefile bin_SCRIPTS >>$NAME
+
+# gnuradio-sounder
+NAME=debian/gnuradio-sounder.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-sounder/src/python/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-sounder/src/python/Makefile bin_SCRIPTS >>$NAME
diff --git a/debian/gnuradio-radar-mono-firmware.install b/debian/gnuradio-radar-mono-firmware.install
new file mode 100644
index 000000000..a73ec4530
--- /dev/null
+++ b/debian/gnuradio-radar-mono-firmware.install
@@ -0,0 +1,3 @@
+usr/share/usrp/rev2/usrp_radar_mono.rbf
+usr/share/usrp/rev4/usrp_radar_mono.rbf
+
diff --git a/debian/gnuradio-sounder-firmware.install b/debian/gnuradio-sounder-firmware.install
new file mode 100644
index 000000000..9c5e7315c
--- /dev/null
+++ b/debian/gnuradio-sounder-firmware.install
@@ -0,0 +1,3 @@
+usr/share/usrp/rev2/usrp_sounder.rbf
+usr/share/usrp/rev4/usrp_sounder.rbf
+
diff --git a/debian/rules b/debian/rules
index cc8b2bfc9..a0f70f4d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -62,7 +62,7 @@ configure-stamp:
touch configure-stamp
extract: extract-stamp
-extract-stamp: configure-stamp
+extract-stamp: configure-stamp debian/gen-install-files.sh
dh_testdir
debian/gen-install-files.sh
touch $@