summaryrefslogtreecommitdiff
path: root/volk/lib/Makefile.am
diff options
context:
space:
mode:
authorNick Foster2011-02-16 17:20:09 -0800
committerNick Foster2011-02-16 17:20:09 -0800
commit0eeeb636a89c5086293bae31511316e4200ad2f9 (patch)
treeba5d6fa502044257fc24f849e3562b91d2d586c9 /volk/lib/Makefile.am
parent8ac430070308f83e8d88f6ae8cf802ccf5a9cf82 (diff)
downloadgnuradio-0eeeb636a89c5086293bae31511316e4200ad2f9.tar.gz
gnuradio-0eeeb636a89c5086293bae31511316e4200ad2f9.tar.bz2
gnuradio-0eeeb636a89c5086293bae31511316e4200ad2f9.zip
Volk_runtime now does self-initialization. You can call volk_xxx_a16() just like in volk.c.
The first run of each function does the rank_archs call. Subsequent calls proceed with no overhead. volk_init is still being generated but not used at all.
Diffstat (limited to 'volk/lib/Makefile.am')
-rw-r--r--volk/lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/volk/lib/Makefile.am b/volk/lib/Makefile.am
index 2338ac57c..cf8c4f407 100644
--- a/volk/lib/Makefile.am
+++ b/volk/lib/Makefile.am
@@ -53,6 +53,7 @@ AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) \
lib_LTLIBRARIES = \
libvolk.la \
libvolk_runtime.la
+ libvolk_orc.la
EXTRA_DIST = \
volk_mktables.c \
@@ -67,7 +68,6 @@ EXTRA_DIST = \
libvolk_runtime_la_SOURCES = \
$(platform_CODE) \
volk_runtime.c \
- volk_init.c \
volk_rank_archs.c \
volk_cpu.c