summaryrefslogtreecommitdiff
path: root/volk/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan2013-02-21 14:06:38 -0800
committerNicholas Corgan2013-02-21 14:06:38 -0800
commitbcf871942809a746df1ca8e611f525b57b66bda5 (patch)
treeb70d62a15b123a31ea480f02bbf7e200987e5594 /volk/CMakeLists.txt
parent75e3954c0cfcd42898a323a178afabef5ba12e29 (diff)
downloadgnuradio-bcf871942809a746df1ca8e611f525b57b66bda5.tar.gz
gnuradio-bcf871942809a746df1ca8e611f525b57b66bda5.tar.bz2
gnuradio-bcf871942809a746df1ca8e611f525b57b66bda5.zip
volk: Fixed volk_profile MSVC incompatibility
Diffstat (limited to 'volk/CMakeLists.txt')
-rw-r--r--volk/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/volk/CMakeLists.txt b/volk/CMakeLists.txt
index 9519505eb..99f705256 100644
--- a/volk/CMakeLists.txt
+++ b/volk/CMakeLists.txt
@@ -62,6 +62,18 @@ if(NOT CHEETAH_FOUND)
message(FATAL_ERROR "Cheetah templates required to build VOLK")
endif()
+if(MSVC)
+ if (NOT DEFINED BOOST_ALL_DYN_LINK)
+ set(BOOST_ALL_DYN_LINK TRUE)
+ endif()
+ set(BOOST_ALL_DYN_LINK "${BOOST_ALL_DYN_LINK}" CACHE BOOL "boost enable dynamic linking")
+ if(BOOST_ALL_DYN_LINK)
+ add_definitions(-DBOOST_ALL_DYN_LINK) #setup boost auto-linking in msvc
+ else(BOOST_ALL_DYN_LINK)
+ unset(BOOST_REQUIRED_COMPONENTS) #empty components list for static link
+ endif(BOOST_ALL_DYN_LINK)
+endif(MSVC)
+
set(Boost_ADDITIONAL_VERSIONS
"1.35.0" "1.35" "1.36.0" "1.36" "1.37.0" "1.37" "1.38.0" "1.38" "1.39.0" "1.39"
"1.40.0" "1.40" "1.41.0" "1.41" "1.42.0" "1.42" "1.43.0" "1.43" "1.44.0" "1.44"
@@ -71,7 +83,7 @@ set(Boost_ADDITIONAL_VERSIONS
"1.60.0" "1.60" "1.61.0" "1.61" "1.62.0" "1.62" "1.63.0" "1.63" "1.64.0" "1.64"
"1.65.0" "1.65" "1.66.0" "1.66" "1.67.0" "1.67" "1.68.0" "1.68" "1.69.0" "1.69"
)
-find_package(Boost COMPONENTS unit_test_framework)
+find_package(Boost COMPONENTS unit_test_framework filesystem system)
if(NOT Boost_FOUND)
message(FATAL_ERROR "VOLK Requires boost to build")