summaryrefslogtreecommitdiff
path: root/usrp2/host/lib/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2008-09-08 01:00:12 +0000
committerjcorgan2008-09-08 01:00:12 +0000
commite0fcbaee124d3e8c4c11bdda662f88e082352058 (patch)
treea51ef1c8b949681f45e5664478e8515065cfff5b /usrp2/host/lib/Makefile.am
parentc86f6c23c6883f73d953d64c28ab42cedb77e4d7 (diff)
downloadgnuradio-e0fcbaee124d3e8c4c11bdda662f88e082352058.tar.gz
gnuradio-e0fcbaee124d3e8c4c11bdda662f88e082352058.tar.bz2
gnuradio-e0fcbaee124d3e8c4c11bdda662f88e082352058.zip
Merged r9433:9527 from features/gr-usrp2 into trunk. Adds usrp2 and gr-usrp2 top-level components. Trunk passes distcheck with mb-gcc installed, but currently not without them. The key issue is that when mb-gcc is not installed, the build system skips over the usrp2/firmware directory, and the firmware include files don't get put into the dist tarball. But we can't do the usual DIST_SUBDIRS method as the firmware is a subpackage.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@9528 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'usrp2/host/lib/Makefile.am')
-rw-r--r--usrp2/host/lib/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/usrp2/host/lib/Makefile.am b/usrp2/host/lib/Makefile.am
new file mode 100644
index 000000000..5c98600bf
--- /dev/null
+++ b/usrp2/host/lib/Makefile.am
@@ -0,0 +1,67 @@
+#
+# Copyright 2007,2008 Free Software Foundation, Inc.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = \
+ $(USRP2_INCLUDES) \
+ $(BOOST_CPPFLAGS) \
+ $(STD_DEFINES_AND_INCLUDES) \
+ $(CPPUNIT_INCLUDES) \
+ $(GRUEL_INCLUDES)
+
+bin_PROGRAMS = usrp2_socket_opener
+usrp2_socket_opener_SOURCES = usrp2_socket_opener.cc
+
+lib_LTLIBRARIES = \
+ libusrp2.la
+
+libusrp2_la_SOURCES = \
+ control.cc \
+ copiers.cc \
+ copy_handler.cc \
+ data_handler.cc \
+ eth_buffer.cc \
+ ethernet.cc \
+ find.cc \
+ open_usrp2_socket.cc \
+ pktfilter.cc \
+ ring.cc \
+ rx_nop_handler.cc \
+ rx_sample_handler.cc \
+ strtod_si.c \
+ usrp2.cc \
+ usrp2_impl.cc \
+ usrp2_thread.cc
+
+libusrp2_la_LIBADD = \
+ $(OMNITHREAD_LA) \
+ $(GRUEL_LIBS) \
+ $(BOOST_LDFLAGS) $(BOOST_THREAD_LIB)
+
+# Private headers not needed for above the API development
+noinst_HEADERS = \
+ control.h \
+ eth_buffer.h \
+ eth_common.h \
+ ethernet.h \
+ open_usrp2_socket.h \
+ pktfilter.h \
+ ring.h \
+ usrp2_bytesex.h \
+ usrp2_impl.h \
+ usrp2_thread.h