summaryrefslogtreecommitdiff
path: root/usrp/host/swig/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2008-02-08 23:32:10 +0000
committerjcorgan2008-02-08 23:32:10 +0000
commit42d9c6f495503d3d9d2db47a9979036c9233f976 (patch)
treeb4d2be737c3ad6836e62dc35c861e987ea3729e0 /usrp/host/swig/Makefile.am
parent6bf2c048d94e1c673c06c058b23213cd28292520 (diff)
downloadgnuradio-42d9c6f495503d3d9d2db47a9979036c9233f976.tar.gz
gnuradio-42d9c6f495503d3d9d2db47a9979036c9233f976.tar.bz2
gnuradio-42d9c6f495503d3d9d2db47a9979036c9233f976.zip
Merged r7478:7608 from michaelld/t186 into trunk. Adds ability to compile GNU Radio modules individually, using already installed dependent libraries and include files. New functionality is enabled using --with-* on configure command line; existing build options should remain unchanged. Nice work by Michael Dickens, still needs documentation update on wiki.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@7617 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'usrp/host/swig/Makefile.am')
-rw-r--r--usrp/host/swig/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/usrp/host/swig/Makefile.am b/usrp/host/swig/Makefile.am
index c5e4bc567..a7c8b08df 100644
--- a/usrp/host/swig/Makefile.am
+++ b/usrp/host/swig/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2001,2003,2004,2006,2007 Free Software Foundation, Inc.
+# Copyright 2001,2003,2004,2006,2007,2008 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -27,7 +27,8 @@ ourlibdir = $(usrppyexecdir)
INCLUDES = $(USRP_INCLUDES) \
$(PYTHON_CPPFLAGS) \
- -I$(srcdir)
+ -I$(srcdir) \
+ $(WITH_INCLUDES)
LOCAL_IFILES = \
prims.i
@@ -52,7 +53,8 @@ ourpython_PYTHON = \
usrp_prims.py
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(INCLUDES)
+SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(INCLUDES) $(WITH_SWIG_INCLUDES) \
+ $(WITH_INCLUDES)
ourlib_LTLIBRARIES = \