summaryrefslogtreecommitdiff
path: root/usrp/host/lib/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2010-04-26 13:05:03 -0700
committerJohnathan Corgan2010-04-26 13:05:03 -0700
commit665d7a850eeb46bfc6388a98e4a4107648cb6add (patch)
tree722736b80651cd2b6fbde49c7859af50b94d3621 /usrp/host/lib/Makefile.am
parenta3278070d3e991ea0a8f6e62bbfc2a2e177fe8e7 (diff)
parenta40feb1dece1b8064f3f81e669f3ed38b60b6dd8 (diff)
downloadgnuradio-665d7a850eeb46bfc6388a98e4a4107648cb6add.tar.gz
gnuradio-665d7a850eeb46bfc6388a98e4a4107648cb6add.tar.bz2
gnuradio-665d7a850eeb46bfc6388a98e4a4107648cb6add.zip
Merge branch 'wip/remove-mld-threads'
* wip/remove-mld-threads: Further updates for removing omnithreads Update build configuration for OSX omnithreads changeover initial move from mld_threads to gruel:: namespace threads and such Initial changes to remove mld_thread and instead use gruel:: namespace classes
Diffstat (limited to 'usrp/host/lib/Makefile.am')
-rw-r--r--usrp/host/lib/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/usrp/host/lib/Makefile.am b/usrp/host/lib/Makefile.am
index e80f27112..5848412c9 100644
--- a/usrp/host/lib/Makefile.am
+++ b/usrp/host/lib/Makefile.am
@@ -1,7 +1,7 @@
#
# USRP - Universal Software Radio Peripheral
#
-# Copyright (C) 2003,2004,2006,2007,2008,2009 Free Software Foundation, Inc.
+# Copyright (C) 2003,2004,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -31,10 +31,10 @@ libusrp_la_common_LIBADD = \
$(BOOST_THREAD_LIB) \
../misc/libmisc.la
-# darwin fusb requires omnithreads
+# darwin fusb requires gruel (for threading)
if FUSB_TECH_darwin
-AM_CPPFLAGS = $(common_INCLUDES) $(OMNITHREAD_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
-libusrp_la_LIBADD = $(libusrp_la_common_LIBADD) $(OMNITHREAD_LA)
+AM_CPPFLAGS = $(common_INCLUDES) $(GRUEL_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
+libusrp_la_LIBADD = $(libusrp_la_common_LIBADD) $(GRUEL_LA)
libusrp_la_LDFLAGS = $(libusrp_la_common_LDFLAGS) -framework CoreFoundation
else
AM_CPPFLAGS = $(common_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
@@ -70,7 +70,6 @@ darwin_CODE = \
circular_buffer.h \
circular_linked_list.h \
darwin_libusb.h \
- mld_threads.h \
usrp_prims_libusb0.cc