summaryrefslogtreecommitdiff
path: root/usrp/firmware/lib/Makefile.am
diff options
context:
space:
mode:
authormichaelld2008-02-21 19:16:45 +0000
committermichaelld2008-02-21 19:16:45 +0000
commit776da31eb84e146a8adf1e3ca7e017c1d9992ce3 (patch)
treee992059b2d7a647fce943469c704a505a2819bed /usrp/firmware/lib/Makefile.am
parentfd7f6c8cfacb4afaca28b22325f450342edd5218 (diff)
downloadgnuradio-776da31eb84e146a8adf1e3ca7e017c1d9992ce3.tar.gz
gnuradio-776da31eb84e146a8adf1e3ca7e017c1d9992ce3.tar.bz2
gnuradio-776da31eb84e146a8adf1e3ca7e017c1d9992ce3.zip
Merged build_config branch into trunk:
1) Modified top-level run_tests.sh script: a) to execute code for setting or changing the library search path in Darwin (DYLD_LIBRARY_PATH) or Windows (PATH) on those host OSs only, not on other host OSs. b) Added local (to the component making check) library paths to those same search paths, since libtool doesn't do it (unlike in Linux). 2) In all AM Makefiles -except those dealing with USRP firmware-, changes INCLUDES to AM_CPPFLAGS since the former is deprecated. 3) Changed AM_CPPFLAGS to FW_INCLUDES for commands .c.rel in USRP firmware. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@7769 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'usrp/firmware/lib/Makefile.am')
-rw-r--r--usrp/firmware/lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/usrp/firmware/lib/Makefile.am b/usrp/firmware/lib/Makefile.am
index eb42f55e7..a6790f010 100644
--- a/usrp/firmware/lib/Makefile.am
+++ b/usrp/firmware/lib/Makefile.am
@@ -30,7 +30,7 @@ EXTRA_DIST = \
DEFINES=
-INCLUDES=-I$(top_srcdir)/usrp/firmware/include
+FW_INCLUDES=-I$(top_srcdir)/usrp/firmware/include
# with EA = 0, the FX2 implements a portion of the 8051 "external memory"
# on chip. This memory is mapped like this:
@@ -58,7 +58,7 @@ LIBOBJS = \
all: libfx2.lib
.c.rel:
- $(XCC) $(INCLUDES) $(DEFINES) -c $< -o $@
+ $(XCC) $(FW_INCLUDES) $(DEFINES) -c $< -o $@
$(LIBRARY): $(LIBOBJS)
-rm -f $(LIBRARY)