summaryrefslogtreecommitdiff
path: root/mblock/src/lib/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2008-12-20 20:54:52 +0000
committerjcorgan2008-12-20 20:54:52 +0000
commit66dca69648e7fa8fbdd2973f77224ad34198d9a5 (patch)
treed5c67453d04d7f727da5dcac7f427a85ea086983 /mblock/src/lib/Makefile.am
parent8d3704c5af29ef15e3a4490049d2fd6d917bc6d8 (diff)
downloadgnuradio-66dca69648e7fa8fbdd2973f77224ad34198d9a5.tar.gz
gnuradio-66dca69648e7fa8fbdd2973f77224ad34198d9a5.tar.bz2
gnuradio-66dca69648e7fa8fbdd2973f77224ad34198d9a5.zip
Move mblock library include files into separate library. Updates to usrp in-band code to accommodate. Tested with out-of-tree mblock application builds. Trunk passes distcheck.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@10144 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'mblock/src/lib/Makefile.am')
-rw-r--r--mblock/src/lib/Makefile.am21
1 files changed, 4 insertions, 17 deletions
diff --git a/mblock/src/lib/Makefile.am b/mblock/src/lib/Makefile.am
index e8e5f59af..269c8ae22 100644
--- a/mblock/src/lib/Makefile.am
+++ b/mblock/src/lib/Makefile.am
@@ -22,7 +22,8 @@
include $(top_srcdir)/Makefile.common
AM_CPPFLAGS = $(DEFINES) $(OMNITHREAD_INCLUDES) $(PMT_INCLUDES) \
- $(BOOST_CPPFLAGS) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
+ $(BOOST_CPPFLAGS) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES) \
+ $(MBLOCK_INCLUDES)
# disable test until we fix ticket:180
# TESTS = test_mblock
@@ -75,25 +76,11 @@ libmblock_la_LIBADD = \
$(PMT_LA) \
-lstdc++
-include_HEADERS = \
- mb_class_registry.h \
- mb_common.h \
- mb_exception.h \
+noinst_HEADERS = \
mb_gettid.h \
- mb_mblock.h \
- mb_message.h \
- mb_msg_accepter.h \
mb_msg_accepter_msgq.h \
- mb_msg_queue.h \
- mb_port.h \
mb_port_simple.h \
- mb_protocol_class.h \
- mb_runtime.h \
- mb_time.h \
- mb_util.h
-
-
-noinst_HEADERS = \
+ mb_util.h \
mb_connection.h \
mb_endpoint.h \
mb_mblock_impl.h \