summaryrefslogtreecommitdiff
path: root/gruel/src/swig/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-12-03 12:13:23 -0500
committerTom Rondeau2011-12-03 12:13:23 -0500
commit2f48e2a60e76072e5436dde860cd602c3882ce5c (patch)
tree86225c30d21d1bf968fa3bc0af356adde23d9a8b /gruel/src/swig/Makefile.am
parent40e8e55f47d201a2d74e674df39d5e19c82f3e1a (diff)
downloadgnuradio-2f48e2a60e76072e5436dde860cd602c3882ce5c.tar.gz
gnuradio-2f48e2a60e76072e5436dde860cd602c3882ce5c.tar.bz2
gnuradio-2f48e2a60e76072e5436dde860cd602c3882ce5c.zip
docs: adding Python docstrings to gruel/pmt in cmake; dummy file make for autotools to build.
Diffstat (limited to 'gruel/src/swig/Makefile.am')
-rw-r--r--gruel/src/swig/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/gruel/src/swig/Makefile.am b/gruel/src/swig/Makefile.am
index 3261e47c2..bf43e01fa 100644
--- a/gruel/src/swig/Makefile.am
+++ b/gruel/src/swig/Makefile.am
@@ -35,6 +35,18 @@ AM_CPPFLAGS = \
TOP_SWIG_IFILES = \
pmt_swig.i
+TOP_SWIG_DOC_IFILES = \
+ pmt_swig_doc.i
+
+BUILT_SOURCES += \
+ $(TOP_SWIG_DOC_IFILES)
+
+$(TOP_SWIG_DOC_IFILES):
+ `echo "" > $@`
+
+install-data-local:
+ cp -p $(TOP_SWIG_DOC_IFILES) $(swigincludedir)
+
# Install so that they end up available as:
# import gruel.pmt
# This ends up at: