summaryrefslogtreecommitdiff
path: root/gruel/src/lib/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum2011-01-24 00:34:28 -0800
committerJosh Blum2011-02-27 19:58:32 -0800
commite73c25fb9226029f0e50052b1ffacedb3a78622b (patch)
treeb480f83b5b614f67b4c544f955fb85b3c338762e /gruel/src/lib/Makefile.am
parenta02bb131f68d5aa66093310c393562671e389778 (diff)
downloadgnuradio-e73c25fb9226029f0e50052b1ffacedb3a78622b.tar.gz
gnuradio-e73c25fb9226029f0e50052b1ffacedb3a78622b.tar.bz2
gnuradio-e73c25fb9226029f0e50052b1ffacedb3a78622b.zip
gruel thread simplification:
Removed get_new_timeout from thread.h (usrp2_vrt carryover) Basically it was created because of a misunderstanding of the time types; and its only ever called once. This also removes thread.cc Call posix_time::milliseconds in usrp2 control.cc. Notice that it passes a time_duration rather than a ptime (aka system time). Added #include <deque> to gr_buffer.h. It turns out that boost posix_time.hpp implicitly included the deque header which was missing from gr_buffer.h Replaced the include for thread.hpp with only the includes for the boost thread types mentioned in gruel/thread.h. Also, making use of the scoped_lock typedef that comes with boost thread locks. boost 3.5 safe.
Diffstat (limited to 'gruel/src/lib/Makefile.am')
-rw-r--r--gruel/src/lib/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/gruel/src/lib/Makefile.am b/gruel/src/lib/Makefile.am
index b9b35ae10..f37ab27a1 100644
--- a/gruel/src/lib/Makefile.am
+++ b/gruel/src/lib/Makefile.am
@@ -45,7 +45,6 @@ MSG_LIB = msg/libmsg.la
libgruel_la_SOURCES = \
realtime.cc \
sys_pri.cc \
- thread.cc \
thread_body_wrapper.cc \
thread_group.cc