summaryrefslogtreecommitdiff
path: root/grc/freedesktop/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2012-04-07 19:32:10 -0700
committerJohnathan Corgan2012-04-07 19:32:10 -0700
commit9bef26c9271a7b9253075bda3c1fc7c8078c0343 (patch)
treea6c1329bb902c95c8ab9970f38ec5fb46d79167c /grc/freedesktop/Makefile.am
parentf621a52f779381cfe550b4278b83e701a747944c (diff)
parentef72dc714840dfb8fe3f918dda243f74453b6cc7 (diff)
downloadgnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.tar.gz
gnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.tar.bz2
gnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.zip
Merge branch 'next'
Diffstat (limited to 'grc/freedesktop/Makefile.am')
-rw-r--r--grc/freedesktop/Makefile.am55
1 files changed, 0 insertions, 55 deletions
diff --git a/grc/freedesktop/Makefile.am b/grc/freedesktop/Makefile.am
deleted file mode 100644
index f89a344f7..000000000
--- a/grc/freedesktop/Makefile.am
+++ /dev/null
@@ -1,55 +0,0 @@
-#
-# Copyright 2008-2011 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-#
-
-include $(top_srcdir)/Makefile.common
-
-ourdatadir = $(pkgdatadir)/grc/freedesktop
-dist_ourdata_DATA = \
- grc-icon-256.png \
- grc-icon-128.png \
- grc-icon-64.png \
- grc-icon-48.png \
- grc-icon-32.png \
- gnuradio-grc.xml \
- gnuradio-grc.desktop
-
-pkglibexecdir = $(libexecdir)/$(PACKAGE)
-dist_pkglibexec_SCRIPTS = grc_setup_freedesktop
-
-grc_setup_freedesktop: $(srcdir)/grc_setup_freedesktop.in Makefile
- sed -e 's|@SRCDIR[@]|$(ourdatadir)|g' $< > $@
-
-EXTRA_DIST += $(srcdir)/grc_setup_freedesktop.in
-BUILT_SOURCES += grc_setup_freedesktop
-
-if XDG_UTILS
-install-data-hook:
- @printf "\n*** GRC Post-Install Message ***\
- \nTo install icons, mime type, and menu items\
- \nfor a freedesktop.org system (Gnome/KDE/Xfce):\
- \n >>> sudo $(pkglibexecdir)/grc_setup_freedesktop install\n\n"
-
-uninstall-hook:
- @printf "\n*** GRC Post-Uninstall Message ***\
- \nTo uninstall icons, mime type, and menu items\
- \nfor a freedesktop.org system (Gnome/KDE/Xfce):\
- \n >>> sudo $(pkglibexecdir)/grc_setup_freedesktop uninstall\n\n"
-endif