summaryrefslogtreecommitdiff
path: root/gr-vocoder/swig/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-12-04 11:10:13 -0500
committerTom Rondeau2011-12-04 11:10:13 -0500
commitfe2e6f8054ed8c6a19fe893553a0d05ce855179e (patch)
treebdce8a051d53a33872479233dfe6171d8763732f /gr-vocoder/swig/Makefile.am
parent2f48e2a60e76072e5436dde860cd602c3882ce5c (diff)
downloadgnuradio-fe2e6f8054ed8c6a19fe893553a0d05ce855179e.tar.gz
gnuradio-fe2e6f8054ed8c6a19fe893553a0d05ce855179e.tar.bz2
gnuradio-fe2e6f8054ed8c6a19fe893553a0d05ce855179e.zip
docs: better install of swig docs .i files since we actually have a variable to take care of it already.
Diffstat (limited to 'gr-vocoder/swig/Makefile.am')
-rw-r--r--gr-vocoder/swig/Makefile.am41
1 files changed, 21 insertions, 20 deletions
diff --git a/gr-vocoder/swig/Makefile.am b/gr-vocoder/swig/Makefile.am
index e075124e3..ba806b27f 100644
--- a/gr-vocoder/swig/Makefile.am
+++ b/gr-vocoder/swig/Makefile.am
@@ -50,12 +50,12 @@ TOP_SWIG_DOC_IFILES = \
BUILT_SOURCES += \
$(TOP_SWIG_DOC_IFILES)
+EXTRA_DIST += \
+ $(TOP_SWIG_DOC_IFILES)
+
$(TOP_SWIG_DOC_IFILES):
`echo "" > $@`
-install-data-local:
- cp -p $(TOP_SWIG_DOC_IFILES) $(swigincludedir)
-
# Install so that they end up available as:
# import gnuradio.vocoder
# This ends up at:
@@ -68,23 +68,24 @@ vocoder_swig_la_swig_libadd = \
$(abs_top_builddir)/gr-vocoder/lib/libgnuradio-vocoder.la
# additional SWIG files to be installed
-vocoder_swig_swiginclude_headers = \
- vocoder_alaw_decode_bs.i \
- vocoder_alaw_encode_sb.i \
- vocoder_codec2_decode_ps.i \
- vocoder_codec2_encode_sp.i \
- vocoder_cvsd_decode_bs.i \
- vocoder_cvsd_encode_sb.i \
- vocoder_g721_decode_bs.i \
- vocoder_g721_encode_sb.i \
- vocoder_g723_24_decode_bs.i \
- vocoder_g723_24_encode_sb.i \
- vocoder_g723_40_decode_bs.i \
- vocoder_g723_40_encode_sb.i \
- vocoder_gsm_fr_encode_sp.i \
- vocoder_gsm_fr_decode_ps.i \
- vocoder_ulaw_decode_bs.i \
- vocoder_ulaw_encode_sb.i
+vocoder_swig_swiginclude_headers = \
+ vocoder_alaw_decode_bs.i \
+ vocoder_alaw_encode_sb.i \
+ vocoder_codec2_decode_ps.i \
+ vocoder_codec2_encode_sp.i \
+ vocoder_cvsd_decode_bs.i \
+ vocoder_cvsd_encode_sb.i \
+ vocoder_g721_decode_bs.i \
+ vocoder_g721_encode_sb.i \
+ vocoder_g723_24_decode_bs.i \
+ vocoder_g723_24_encode_sb.i \
+ vocoder_g723_40_decode_bs.i \
+ vocoder_g723_40_encode_sb.i \
+ vocoder_gsm_fr_encode_sp.i \
+ vocoder_gsm_fr_decode_ps.i \
+ vocoder_ulaw_decode_bs.i \
+ vocoder_ulaw_encode_sb.i \
+ $(TOP_SWIG_DOC_IFILE)
vocoder_swig_swig_args = \
-I$(abs_top_builddir)/gr-vocoder/lib