summaryrefslogtreecommitdiff
path: root/gr-vocoder/lib/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2011-07-18 15:54:43 -0700
committerJohnathan Corgan2011-07-18 16:36:15 -0700
commitb409a4b0c6131e01fc5a03c0fc31caa4829b0dec (patch)
tree51ec0115bd114716672f0659800cda933cfc77dd /gr-vocoder/lib/Makefile.am
parentc067ea65d7433d4111b344ded6dfbf089062cf33 (diff)
downloadgnuradio-b409a4b0c6131e01fc5a03c0fc31caa4829b0dec.tar.gz
gnuradio-b409a4b0c6131e01fc5a03c0fc31caa4829b0dec.tar.bz2
gnuradio-b409a4b0c6131e01fc5a03c0fc31caa4829b0dec.zip
gr-vocoder: re-implemented gr-codec2-vocoder inside gr-vocoder
Diffstat (limited to 'gr-vocoder/lib/Makefile.am')
-rw-r--r--gr-vocoder/lib/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/gr-vocoder/lib/Makefile.am b/gr-vocoder/lib/Makefile.am
index ec97d96b6..198371f47 100644
--- a/gr-vocoder/lib/Makefile.am
+++ b/gr-vocoder/lib/Makefile.am
@@ -21,7 +21,7 @@
include $(top_srcdir)/Makefile.common
-SUBDIRS = gsm .
+SUBDIRS = codec2 gsm .
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES) \
-I$(top_srcdir)/gr-vocoder/include
@@ -29,6 +29,8 @@ AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES) \
lib_LTLIBRARIES = libgnuradio-vocoder.la
libgnuradio_vocoder_la_SOURCES = \
+ vocoder_codec2_decode_ps.cc \
+ vocoder_codec2_encode_sp.cc \
vocoder_cvsd_encode_sb.cc \
vocoder_cvsd_decode_bs.cc \
vocoder_gsm_fr_decode_ps.cc \
@@ -36,6 +38,7 @@ libgnuradio_vocoder_la_SOURCES = \
libgnuradio_vocoder_la_LIBADD = \
$(GNURADIO_CORE_LA) \
+ codec2/libcodec2.la \
gsm/libgsm.la
libgnuradio_vocoder_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)