summaryrefslogtreecommitdiff
path: root/gr-utils/src/python/modtool/gr-newmod/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun2013-01-25 15:43:02 +0100
committerMartin Braun2013-01-25 17:03:49 +0100
commitf24128ea9036f68e61ff9350ce86ec619f9ae286 (patch)
tree471a35e5354836da1fc173626a4829d2d2e2b310 /gr-utils/src/python/modtool/gr-newmod/lib/CMakeLists.txt
parenta62f90d8cc96b9dea9289ad6e420d1c0b16f6c36 (diff)
downloadgnuradio-f24128ea9036f68e61ff9350ce86ec619f9ae286.tar.gz
gnuradio-f24128ea9036f68e61ff9350ce86ec619f9ae286.tar.bz2
gnuradio-f24128ea9036f68e61ff9350ce86ec619f9ae286.zip
utils: modtool now installs an example dir instead of the bz2
Diffstat (limited to 'gr-utils/src/python/modtool/gr-newmod/lib/CMakeLists.txt')
-rw-r--r--gr-utils/src/python/modtool/gr-newmod/lib/CMakeLists.txt63
1 files changed, 63 insertions, 0 deletions
diff --git a/gr-utils/src/python/modtool/gr-newmod/lib/CMakeLists.txt b/gr-utils/src/python/modtool/gr-newmod/lib/CMakeLists.txt
new file mode 100644
index 000000000..f975d86e8
--- /dev/null
+++ b/gr-utils/src/python/modtool/gr-newmod/lib/CMakeLists.txt
@@ -0,0 +1,63 @@
+# Copyright 2011,2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup library
+########################################################################
+include(GrPlatform) #define LIB_SUFFIX
+
+include_directories(${Boost_INCLUDE_DIR})
+link_directories(${Boost_LIBRARY_DIRS})
+
+add_library(gnuradio-howto SHARED )
+target_link_libraries(gnuradio-howto ${Boost_LIBRARIES} ${GRUEL_LIBRARIES} ${GNURADIO_CORE_LIBRARIES})
+set_target_properties(gnuradio-howto PROPERTIES DEFINE_SYMBOL "gnuradio_howto_EXPORTS")
+
+########################################################################
+# Install built library files
+########################################################################
+install(TARGETS gnuradio-howto
+ LIBRARY DESTINATION lib${LIB_SUFFIX} # .so/.dylib file
+ ARCHIVE DESTINATION lib${LIB_SUFFIX} # .lib file
+ RUNTIME DESTINATION bin # .dll file
+)
+
+########################################################################
+# Build and register unit test
+########################################################################
+include(GrTest)
+
+include_directories(${CPPUNIT_INCLUDE_DIRS})
+
+list(APPEND test_howto_sources
+ ${CMAKE_CURRENT_SOURCE_DIR}/test_howto.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/qa_howto.cc
+)
+
+add_executable(test-howto ${test_howto_sources})
+
+target_link_libraries(
+ test-howto
+ ${GNURADIO_CORE_LIBRARIES}
+ ${Boost_LIBRARIES}
+ ${CPPUNIT_LIBRARIES}
+ gnuradio-howto
+)
+
+GR_ADD_TEST(test_howto test-howto)