summaryrefslogtreecommitdiff
path: root/gr-utils/src/python/modtool/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun2013-01-25 15:43:02 +0100
committerMartin Braun2013-01-25 17:03:49 +0100
commitf24128ea9036f68e61ff9350ce86ec619f9ae286 (patch)
tree471a35e5354836da1fc173626a4829d2d2e2b310 /gr-utils/src/python/modtool/CMakeLists.txt
parenta62f90d8cc96b9dea9289ad6e420d1c0b16f6c36 (diff)
downloadgnuradio-f24128ea9036f68e61ff9350ce86ec619f9ae286.tar.gz
gnuradio-f24128ea9036f68e61ff9350ce86ec619f9ae286.tar.bz2
gnuradio-f24128ea9036f68e61ff9350ce86ec619f9ae286.zip
utils: modtool now installs an example dir instead of the bz2
Diffstat (limited to 'gr-utils/src/python/modtool/CMakeLists.txt')
-rw-r--r--gr-utils/src/python/modtool/CMakeLists.txt24
1 files changed, 23 insertions, 1 deletions
diff --git a/gr-utils/src/python/modtool/CMakeLists.txt b/gr-utils/src/python/modtool/CMakeLists.txt
index 3425b50d0..7647c86f6 100644
--- a/gr-utils/src/python/modtool/CMakeLists.txt
+++ b/gr-utils/src/python/modtool/CMakeLists.txt
@@ -30,7 +30,6 @@ GR_PYTHON_INSTALL(FILES
modtool_makexml.py
modtool_newmod.py
modtool_rm.py
- newmod_tarfile.py
parser_cc_block.py
templates.py
util_functions.py
@@ -38,3 +37,26 @@ GR_PYTHON_INSTALL(FILES
COMPONENT "utils"
)
+set(GR_PKG_MODTOOL_DATA_DIR ${GR_PKG_DATA_DIR}/modtool)
+install(DIRECTORY gr-newmod
+ DESTINATION ${GR_PKG_MODTOOL_DATA_DIR}
+ COMPONENT "utils"
+)
+
+
+########################################################################
+# Create and install the modtool conf file
+########################################################################
+file(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/${GR_PKG_MODTOOL_DATA_DIR}/gr-newmod newmoddir)
+
+configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/modtool.conf.in
+ ${CMAKE_CURRENT_BINARY_DIR}/modtool.conf
+@ONLY)
+
+install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/modtool.conf
+ DESTINATION ${GR_PREFSDIR}
+ COMPONENT "utils"
+)
+