summaryrefslogtreecommitdiff
path: root/gr-utils/src/python/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2008-02-01 16:48:00 +0000
committerjcorgan2008-02-01 16:48:00 +0000
commit6c7ee8932b84fa5dca0c88d7d80f2efe0aa30a06 (patch)
tree49ad5bb39263b23426f91442eff20b860fa25d19 /gr-utils/src/python/Makefile.am
parent42271ef69334b0b9236bdbfd8aa26c2848249d6d (diff)
downloadgnuradio-6c7ee8932b84fa5dca0c88d7d80f2efe0aa30a06.tar.gz
gnuradio-6c7ee8932b84fa5dca0c88d7d80f2efe0aa30a06.tar.bz2
gnuradio-6c7ee8932b84fa5dca0c88d7d80f2efe0aa30a06.zip
Moved gnuradio-core/src/utils/ plotting scripts into gr-utils, with some rework.
The gr_plot_data.py class installs into the gnuradio namespace as gnuradio.plot_data, and the remainder of the scripts install into $prefix/bin. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@7536 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-utils/src/python/Makefile.am')
-rw-r--r--gr-utils/src/python/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/gr-utils/src/python/Makefile.am b/gr-utils/src/python/Makefile.am
index 231153636..8b190d660 100644
--- a/gr-utils/src/python/Makefile.am
+++ b/gr-utils/src/python/Makefile.am
@@ -19,10 +19,26 @@
# Boston, MA 02110-1301, USA.
#
+include $(top_srcdir)/Makefile.common
+
EXTRA_DIST = \
- $(bin_SCRIPTS)
+ $(bin_SCRIPTS) \
+ README.plot
+
+ourpythondir = $(grpythondir)
+
+ourpython_PYTHON = \
+ plot_data.py
bin_SCRIPTS = \
+ gr_plot_char.py \
+ gr_plot_const.py \
+ gr_plot_fft_c.py \
+ gr_plot_fft_f.py \
+ gr_plot_float.py \
+ gr_plot_int.py \
+ gr_plot_iq.py \
+ gr_plot_short.py \
usrp_fft.py \
usrp_oscope.py \
usrp_print_db.py \
@@ -31,3 +47,5 @@ bin_SCRIPTS = \
usrp_siggen.py \
usrp_test_counting.py \
usrp_test_loopback.py
+
+MOSTLYCLEANFILES = *~ *.pyc