summaryrefslogtreecommitdiff
path: root/gr-usrp2/src/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-06-05 15:36:47 -0400
committerTom Rondeau2011-06-05 15:36:47 -0400
commit233f960474f86bc8cc519ce7257b29d8615c4000 (patch)
tree1a4c846119a01a5a195a9e9ee5b854384b0b6535 /gr-usrp2/src/Makefile.am
parent024c79a7fb13c08bae7b97079a245f711ecf12a7 (diff)
parenta23a0a46c3bf446cbe09d71bc8e10b061256ef56 (diff)
downloadgnuradio-233f960474f86bc8cc519ce7257b29d8615c4000.tar.gz
gnuradio-233f960474f86bc8cc519ce7257b29d8615c4000.tar.bz2
gnuradio-233f960474f86bc8cc519ce7257b29d8615c4000.zip
Merge branch 'master' into turbo
Diffstat (limited to 'gr-usrp2/src/Makefile.am')
-rw-r--r--gr-usrp2/src/Makefile.am48
1 files changed, 23 insertions, 25 deletions
diff --git a/gr-usrp2/src/Makefile.am b/gr-usrp2/src/Makefile.am
index 0d55d73ba..a84637f73 100644
--- a/gr-usrp2/src/Makefile.am
+++ b/gr-usrp2/src/Makefile.am
@@ -20,21 +20,18 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
-# ----------------------------------------------------------------------
-# Local Python files, not installed
-#
-# qa_usrp2.py
-# ----------------------------------------------------------------------
+TESTS =
+EXTRA_DIST += run_tests.in run_guile_tests.in $(nobase_guile_DATA)
+DISTCLEANFILES += run_tests run_guile_tests
noinst_PYTHON = qa_usrp2.py
+noinst_GUILE = usrp2.test
-# ----------------------------------------------------------------------
-# Miscellaneous build operations
-# ----------------------------------------------------------------------
-
-EXTRA_DIST = run_tests.in
-DISTCLEANFILES = run_tests
+if GUILE
+nobase_guile_DATA = gnuradio/usrp2.scm
+endif
# ----------------------------------------------------------------------
# C++ block API interface librar(ies)
@@ -80,38 +77,39 @@ noinst_HEADERS = \
rx_16sc_handler.h \
rx_32fc_handler.h
-if PYTHON
# ----------------------------------------------------------------------
-# Python SWIG wrapper around C++ library
+# SWIG wrappers around C++ library
#
# usrp2.py
# _usrp2.so
# ----------------------------------------------------------------------
-TESTS = run_tests
TOP_SWIG_IFILES = \
- usrp2.i
+ usrp2_swig.i
# Install so that they end up available as:
# import gnuradio.usrp2
# This ends up at:
-# ${prefix}/lib/python${python_version}/site-packages/gnuradio
-usrp2_pythondir_category = \
- gnuradio
+# ${prefix}/lib/python${python_version}/site-packages/gnuradio/usrp2
+usrp2_swig_pythondir_category = \
+ gnuradio/usrp2
# additional arguments to the SWIG command
-usrp2_swig_args = \
+usrp2_swig_swig_args = \
$(USRP2_INCLUDES)
# additional libraries for linking with the SWIG-generated library
-usrp2_la_swig_libadd = \
+usrp2_swig_la_swig_libadd = \
libgnuradio-usrp2.la
-include $(top_srcdir)/Makefile.swig
+# additional Python files to be installed along with the SWIG-generated one
+usrp2_swig_python = \
+ __init__.py
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
+if PYTHON
+TESTS += run_tests
+endif
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
+if GUILE
+TESTS += run_guile_tests
endif