summaryrefslogtreecommitdiff
path: root/gr-usrp/src/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2006-08-03 04:51:51 +0000
committerjcorgan2006-08-03 04:51:51 +0000
commit5d69a524f81f234b3fbc41d49ba18d6f6886baba (patch)
treeb71312bf7f1e8d10fef0f3ac6f28784065e73e72 /gr-usrp/src/Makefile.am
downloadgnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.tar.gz
gnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.tar.bz2
gnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.zip
Houston, we have a trunk.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3122 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-usrp/src/Makefile.am')
-rw-r--r--gr-usrp/src/Makefile.am120
1 files changed, 120 insertions, 0 deletions
diff --git a/gr-usrp/src/Makefile.am b/gr-usrp/src/Makefile.am
new file mode 100644
index 000000000..0bcd6c475
--- /dev/null
+++ b/gr-usrp/src/Makefile.am
@@ -0,0 +1,120 @@
+#
+# Copyright 2004,2005,2006 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+# Install this stuff so that it ends up as the gnuradio.usrp module
+# This usually ends up at:
+# ${prefix}/lib/python${python_version}/site-packages/gnuradio
+
+ourpythondir = $(grpythondir)
+ourlibdir = $(grpyexecdir)
+
+EXTRA_DIST = run_tests.in
+TESTS = run_tests
+
+LOCAL_IFILES = \
+ usrp1.i
+
+NON_LOCAL_IFILES = \
+ $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+
+ALL_IFILES = \
+ $(LOCAL_IFILES) \
+ $(NON_LOCAL_IFILES)
+
+BUILT_SOURCES = \
+ usrp1.cc \
+ usrp1.py
+
+ourpython_PYTHON = \
+ db_base.py \
+ db_basic.py \
+ db_dbs_rx.py \
+ db_flexrf.py \
+ db_flexrf_mimo.py \
+ db_instantiator.py \
+ db_tv_rx.py \
+ flexrf_debug_gui.py \
+ tx_debug_gui.py \
+ usrp.py \
+ usrp1.py \
+ usrp_multi.py
+
+
+USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib -I$(top_srcdir)/usrp/firmware/include
+USRP_LIBS = -L$(top_srcdir)/usrp/host/lib/.libs -lusrp
+
+INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
+
+SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES) $(USRP_INCLUDES)
+
+grinclude_HEADERS = \
+ usrp1_sink_base.h \
+ usrp1_sink_c.h \
+ usrp1_sink_s.h \
+ usrp1_source_base.h \
+ usrp1_source_c.h \
+ usrp1_source_s.h
+
+swiginclude_HEADERS = \
+ $(LOCAL_IFILES)
+
+
+ourlib_LTLIBRARIES = _usrp1.la
+
+
+_usrp1_la_SOURCES = \
+ usrp1.cc \
+ usrp1_sink_base.cc \
+ usrp1_sink_c.cc \
+ usrp1_sink_s.cc \
+ usrp1_source_base.cc \
+ usrp1_source_c.cc \
+ usrp1_source_s.cc
+
+
+_usrp1_la_LIBADD = \
+ $(PYTHON_LDFLAGS) \
+ $(GNURADIO_CORE_LIBS) \
+ $(USRP_LIBS) \
+ -lstdc++
+
+
+_usrp1_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
+
+
+usrp1.cc usrp1.py: usrp1.i $(NON_LOCAL_IFILES)
+ $(SWIG) $(SWIGPYTHONARGS) -module usrp1 -o usrp1.cc $<
+
+
+noinst_PYTHON = \
+ qa_usrp.py
+
+MOSTLYCLEANFILES = \
+ $(BUILT_SOURCES) *~ *.pyc
+
+
+# Don't distribute output of swig
+dist-hook:
+ @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
+ @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done
+