summaryrefslogtreecommitdiff
path: root/gr-uhd/swig/Makefile.am
diff options
context:
space:
mode:
authorEric Blossom2010-11-24 17:29:11 -0800
committerEric Blossom2010-11-24 17:29:11 -0800
commitd692a41f98e7b888c745efbb9fcbbb0400f39025 (patch)
tree591782e695d1d29f2dfcfe6390fc21cd99a06a16 /gr-uhd/swig/Makefile.am
parent42fe3e571be14e70cb06ea1244125553f0606be4 (diff)
downloadgnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.tar.gz
gnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.tar.bz2
gnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.zip
Major Makefile.am housecleaning. Passes distcheck.
Move all occurrences of swig_built_sources out of Makefile.am's. Move all SWIG related use of BUILT_SOURCES out of Makefile.am's. Clean up 'if PYTHON' conditionalization in gr-* Still left to do: fix Makefile.swig CLEANFILES and no_dist_files such that they remove exactly the generated files.
Diffstat (limited to 'gr-uhd/swig/Makefile.am')
-rw-r--r--gr-uhd/swig/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/gr-uhd/swig/Makefile.am b/gr-uhd/swig/Makefile.am
index abf38b293..11c0cabb2 100644
--- a/gr-uhd/swig/Makefile.am
+++ b/gr-uhd/swig/Makefile.am
@@ -22,6 +22,8 @@
include $(top_srcdir)/Makefile.common
include $(top_srcdir)/Makefile.swig
+EXTRA_DIST += $(nobase_guile_DATA)
+
AM_CPPFLAGS = \
$(STD_DEFINES_AND_INCLUDES) \
$(PYTHON_CPPFLAGS) \
@@ -59,13 +61,6 @@ uhd_swig_python = \
# additional SWIG files to be installed
uhd_swig_swiginclude_headers =
-
uhd_swig_swig_args = \
$(UHD_CFLAGS) \
-I$(top_srcdir)/gr-uhd/lib
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)