summaryrefslogtreecommitdiff
path: root/gr-uhd/include/Makefile.am
diff options
context:
space:
mode:
authorThomas Tsou2011-08-19 14:50:55 -0700
committerThomas Tsou2011-08-19 18:30:38 -0700
commit893f946b7a652497994309092fe84fb33504852c (patch)
tree064fa60b78a04565ba559a29a2f7bf824b63473e /gr-uhd/include/Makefile.am
parentdc16937c935f10a16de8969ca592b6019639d52b (diff)
downloadgnuradio-893f946b7a652497994309092fe84fb33504852c.tar.gz
gnuradio-893f946b7a652497994309092fe84fb33504852c.tar.bz2
gnuradio-893f946b7a652497994309092fe84fb33504852c.zip
gr-uhd: add async metadata source block
Add asynchronous message "block" that is independent of normal gnuradio scheduler. The block instantiates a thread to wait for asynchronous messages from UHD and encapsulates them in a gr_message posted into a message queue. The interface is empty because the block is internally driven and accessed through the the constructor specified message queue.
Diffstat (limited to 'gr-uhd/include/Makefile.am')
-rw-r--r--gr-uhd/include/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gr-uhd/include/Makefile.am b/gr-uhd/include/Makefile.am
index 4a04c98c1..70b80681b 100644
--- a/gr-uhd/include/Makefile.am
+++ b/gr-uhd/include/Makefile.am
@@ -24,4 +24,5 @@ include $(top_srcdir)/Makefile.common
grinclude_HEADERS = \
gr_uhd_api.h \
gr_uhd_usrp_source.h \
- gr_uhd_usrp_sink.h
+ gr_uhd_usrp_sink.h \
+ gr_uhd_amsg_source.h