summaryrefslogtreecommitdiff
path: root/gr-uhd/examples/c++/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan2012-04-07 19:32:10 -0700
committerJohnathan Corgan2012-04-07 19:32:10 -0700
commit9bef26c9271a7b9253075bda3c1fc7c8078c0343 (patch)
treea6c1329bb902c95c8ab9970f38ec5fb46d79167c /gr-uhd/examples/c++/CMakeLists.txt
parentf621a52f779381cfe550b4278b83e701a747944c (diff)
parentef72dc714840dfb8fe3f918dda243f74453b6cc7 (diff)
downloadgnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.tar.gz
gnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.tar.bz2
gnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.zip
Merge branch 'next'
Diffstat (limited to 'gr-uhd/examples/c++/CMakeLists.txt')
-rw-r--r--gr-uhd/examples/c++/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/gr-uhd/examples/c++/CMakeLists.txt b/gr-uhd/examples/c++/CMakeLists.txt
new file mode 100644
index 000000000..25645117c
--- /dev/null
+++ b/gr-uhd/examples/c++/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup the include and linker paths
+########################################################################
+include_directories(
+ ${GNURADIO_CORE_INCLUDE_DIRS}
+ ${GR_UHD_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+include_directories(${UHD_INCLUDE_DIRS})
+link_directories(${UHD_LIBRARY_DIRS})
+
+include_directories(${Boost_INCLUDE_DIRS})
+link_directories(${Boost_LIBRARY_DIRS})
+
+########################################################################
+# Build executable
+########################################################################
+add_executable(tags_demo tags_demo.cc)
+target_link_libraries(tags_demo gnuradio-uhd)
+
+INSTALL(TARGETS
+ tags_demo
+ DESTINATION ${GR_PKG_UHD_EXAMPLES_DIR}
+ COMPONENT "uhd_examples"
+)