summaryrefslogtreecommitdiff
path: root/gr-uhd/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2011-09-26 12:13:54 -0700
committerJosh Blum2011-09-26 12:13:54 -0700
commit2ccb1266791d0e7c6a58ccd56df1b00647d52b46 (patch)
treef3393f159daa72549750ae30e8dd7c2c4a1fa6cb /gr-uhd/examples/CMakeLists.txt
parent1ff42298b8c5216587ecddcd3a3571def2e5fa21 (diff)
downloadgnuradio-2ccb1266791d0e7c6a58ccd56df1b00647d52b46.tar.gz
gnuradio-2ccb1266791d0e7c6a58ccd56df1b00647d52b46.tar.bz2
gnuradio-2ccb1266791d0e7c6a58ccd56df1b00647d52b46.zip
uhd: cmake support for example application
Diffstat (limited to 'gr-uhd/examples/CMakeLists.txt')
-rw-r--r--gr-uhd/examples/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/gr-uhd/examples/CMakeLists.txt b/gr-uhd/examples/CMakeLists.txt
new file mode 100644
index 000000000..3e1c80362
--- /dev/null
+++ b/gr-uhd/examples/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup the include and linker paths
+########################################################################
+INCLUDE_DIRECTORIES(
+ ${GNURADIO_CORE_INCLUDE_DIRS}
+ ${GR_UHD_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+INCLUDE_DIRECTORIES(${UHD_INCLUDE_DIRS})
+LINK_DIRECTORIES(${UHD_LIBRARY_DIRS})
+
+INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
+LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+
+########################################################################
+# Build executable
+########################################################################
+ADD_EXECUTABLE(tags_demo tags_demo.cc)
+TARGET_LINK_LIBRARIES(tags_demo gnuradio-uhd)