summaryrefslogtreecommitdiff
path: root/gr-trellis/src/lib/Makefile.am
diff options
context:
space:
mode:
authoreb2006-08-07 16:28:55 +0000
committereb2006-08-07 16:28:55 +0000
commite9a821632def12c450110e164d0d1c0275d41946 (patch)
treefb21aedc8c457039e5c6482a1730f90de0f1e136 /gr-trellis/src/lib/Makefile.am
parent5d94acf997672a5101db4984a590aa4f1d2d6e03 (diff)
downloadgnuradio-e9a821632def12c450110e164d0d1c0275d41946.tar.gz
gnuradio-e9a821632def12c450110e164d0d1c0275d41946.tar.bz2
gnuradio-e9a821632def12c450110e164d0d1c0275d41946.zip
Merged anastas/wip changes r3156:3218 into trunk.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3219 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-trellis/src/lib/Makefile.am')
-rw-r--r--gr-trellis/src/lib/Makefile.am97
1 files changed, 97 insertions, 0 deletions
diff --git a/gr-trellis/src/lib/Makefile.am b/gr-trellis/src/lib/Makefile.am
new file mode 100644
index 000000000..cc8fe3893
--- /dev/null
+++ b/gr-trellis/src/lib/Makefile.am
@@ -0,0 +1,97 @@
+#
+# Copyright 2004,2005,2006 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+include Makefile.gen
+
+# Install this stuff so that it ends up as the gnuradio.trellis module
+# This usually ends up at:
+# ${prefix}/lib/python${python_version}/site-packages/gnuradio
+
+ourpythondir = $(grpythondir)
+ourlibdir = $(grpyexecdir)
+
+INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
+
+SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES)
+
+ALL_IFILES = \
+ $(LOCAL_IFILES) \
+ $(NON_LOCAL_IFILES)
+
+NON_LOCAL_IFILES = \
+ $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+
+
+LOCAL_IFILES = \
+ trellis.i
+
+
+# These files are built by SWIG. The first is the C++ glue.
+# The second is the python wrapper that loads the _trellis shared library
+# and knows how to call our extensions.
+
+BUILT_SOURCES = \
+ trellis.cc \
+ trellis.py
+
+# This gets trellis.py installed in the right place
+ourpython_PYTHON = \
+ trellis.py
+
+ourlib_LTLIBRARIES = _trellis.la
+
+# These are the source files that go into the shared library
+_trellis_la_SOURCES = \
+ trellis.cc \
+ fsm.cc \
+ trellis_calc_metric.cc \
+ $(GENERATED_CC)
+
+# magic flags
+_trellis_la_LDFLAGS = -module -avoid-version
+
+# link the library against some comon swig runtime code and the
+# c++ standard library
+_trellis_la_LIBADD = \
+ $(PYTHON_LDFLAGS) \
+ $(GNURADIO_CORE_LIBS) \
+ -lstdc++
+
+trellis.cc trellis.py: trellis.i $(ALL_IFILES)
+ $(SWIG) $(SWIGPYTHONARGS) -module trellis -o trellis.cc $<
+
+# These headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS = \
+ fsm.h \
+ trellis_metric_type.h \
+ trellis_calc_metric.h \
+ $(GENERATED_H)
+
+
+# These swig headers get installed in ${prefix}/include/gnuradio/swig
+swiginclude_HEADERS = \
+ $(LOCAL_IFILES)
+
+
+MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
+