summaryrefslogtreecommitdiff
path: root/gr-trellis/src/lib/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2009-05-27 01:54:41 +0000
committerjcorgan2009-05-27 01:54:41 +0000
commit40b8a57d69b4b85f207fb0408347c210e23202cc (patch)
tree8d1e3bbc9159bdd0de98bb897432abd81563dbca /gr-trellis/src/lib/Makefile.am
parente3cd8f7d59aad0ffd51c417b2623ab02588fdb08 (diff)
downloadgnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.tar.gz
gnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.tar.bz2
gnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.zip
Merged r11123:11148 from jcorgan/np into trunk.
Adds --enable-python option to configure (defaults to yes). Using --disable-python or --enable-python=no will cause only C++ API targets to be created and installed. Several new shared libraries are now created. Where in the past, the C++ objects of the actual gnuradio blocks that were in a component were hidden inside their corresponding Python extension modules, these are now split out into a libgnuradio-foo.so library, and the _foo.so Python module is linked to that. This has been the way several top- level components have operated for some time, such as gr-audio-alsa and gr-usrp and gr-usrp2. This changeset applies that pattern to all components. C++ API users can use pkg-config to discover the cflags and libs parameters needed to include and link against these libraries. These components have not been tested: gr-comedi gr-audio-osx gr-audio-windows Passes distcheck. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11150 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-trellis/src/lib/Makefile.am')
-rw-r--r--gr-trellis/src/lib/Makefile.am38
1 files changed, 25 insertions, 13 deletions
diff --git a/gr-trellis/src/lib/Makefile.am b/gr-trellis/src/lib/Makefile.am
index 2e7591e4b..58115de25 100644
--- a/gr-trellis/src/lib/Makefile.am
+++ b/gr-trellis/src/lib/Makefile.am
@@ -66,6 +66,29 @@ grinclude_HEADERS = \
trellis_siso_combined_f.h \
$(GENERATED_H)
+lib_LTLIBRARIES = libgnuradio-trellis.la
+
+libgnuradio_trellis_la_SOURCES = \
+ fsm.cc \
+ quicksort_index.cc \
+ base.cc \
+ interleaver.cc \
+ trellis_calc_metric.cc \
+ trellis_permutation.cc \
+ trellis_siso_f.cc \
+ trellis_siso_combined_f.cc \
+ $(GENERATED_CC)
+
+libgnuradio_trellis_la_LIBADD = \
+ $(GNURADIO_CORE_LA)
+
+libgnuradio_trellis_la_LDFLAGS = \
+ $(NO_UNDEFINED)
+
+
+
+
+if PYTHON
#################################
# SWIG interface and library
@@ -79,21 +102,9 @@ TOP_SWIG_IFILES = \
trellis_pythondir_category = \
gnuradio
-# additional sources for the SWIG-generated library
-trellis_la_swig_sources = \
- fsm.cc \
- quicksort_index.cc \
- base.cc \
- interleaver.cc \
- trellis_calc_metric.cc \
- trellis_permutation.cc \
- trellis_siso_f.cc \
- trellis_siso_combined_f.cc \
- $(GENERATED_CC)
-
# additional libraries for linking with the SWIG-generated library
trellis_la_swig_libadd = \
- $(GNURADIO_CORE_LA)
+ libgnuradio-trellis.la
# additional SWIG files to be installed
trellis_swiginclude_headers = \
@@ -131,3 +142,4 @@ BUILT_SOURCES = \
# Do not distribute the output of SWIG
no_dist_files = $(swig_built_sources)
+endif