summaryrefslogtreecommitdiff
path: root/gr-shd/lib/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-09-06 18:18:11 -0400
committerTom Rondeau2011-09-06 18:19:25 -0400
commit8743a23066d779dbfbd6d93467cd9cd36fd00e01 (patch)
treec3d1955b0acf893228cffaddbcff287c758572fd /gr-shd/lib/Makefile.am
parent0f43bdb085f98e1182dbd940db9ed1fb52119186 (diff)
downloadgnuradio-8743a23066d779dbfbd6d93467cd9cd36fd00e01.tar.gz
gnuradio-8743a23066d779dbfbd6d93467cd9cd36fd00e01.tar.bz2
gnuradio-8743a23066d779dbfbd6d93467cd9cd36fd00e01.zip
shd: adding a component gr-shd as an interface to the Symplex Hardware X-Mini system. Mostly cribbed from gr-uhd.
Diffstat (limited to 'gr-shd/lib/Makefile.am')
-rw-r--r--gr-shd/lib/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/gr-shd/lib/Makefile.am b/gr-shd/lib/Makefile.am
new file mode 100644
index 000000000..fe0f51e3d
--- /dev/null
+++ b/gr-shd/lib/Makefile.am
@@ -0,0 +1,42 @@
+#
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = \
+ $(STD_DEFINES_AND_INCLUDES) \
+ $(WITH_INCLUDES) \
+ $(SHD_CPPFLAGS) \
+ -Dgnuradio_shd_EXPORTS
+
+lib_LTLIBRARIES = libgnuradio-shd.la
+
+libgnuradio_shd_la_SOURCES = \
+ gr_shd_xmini_source.cc \
+ gr_shd_xmini_sink.cc
+
+libgnuradio_shd_la_LIBADD = \
+ $(GNURADIO_CORE_LA) \
+ $(SHD_LIBS)
+
+libgnuradio_shd_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
+
+noinst_HEADERS =