summaryrefslogtreecommitdiff
path: root/gr-shd/lib/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-10-06 18:23:58 -0400
committerTom Rondeau2011-10-06 18:23:58 -0400
commit646f625d0b16159e03efb64409fe55ac1d07249a (patch)
treefc3938960bd5603b656f7f305658861bf7682d79 /gr-shd/lib/Makefile.am
parent3e8c3125da6234c4d1f8c0eaf869bc86923cb292 (diff)
parentf9b6786c6b4ea6dd1c7435bd0dfa30ef38b727c1 (diff)
downloadgnuradio-646f625d0b16159e03efb64409fe55ac1d07249a.tar.gz
gnuradio-646f625d0b16159e03efb64409fe55ac1d07249a.tar.bz2
gnuradio-646f625d0b16159e03efb64409fe55ac1d07249a.zip
Merge branch 'next' into digital
Diffstat (limited to 'gr-shd/lib/Makefile.am')
-rw-r--r--gr-shd/lib/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/gr-shd/lib/Makefile.am b/gr-shd/lib/Makefile.am
new file mode 100644
index 000000000..7a887aebf
--- /dev/null
+++ b/gr-shd/lib/Makefile.am
@@ -0,0 +1,42 @@
+#
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = \
+ $(STD_DEFINES_AND_INCLUDES) \
+ $(WITH_INCLUDES) \
+ $(SHD_CPPFLAGS) \
+ -Dgnuradio_shd_EXPORTS
+
+lib_LTLIBRARIES = libgnuradio-shd.la
+
+libgnuradio_shd_la_SOURCES = \
+ gr_shd_smini_source.cc \
+ gr_shd_smini_sink.cc
+
+libgnuradio_shd_la_LIBADD = \
+ $(GNURADIO_CORE_LA) \
+ $(SHD_LIBS)
+
+libgnuradio_shd_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
+
+noinst_HEADERS =